РаминаГасымлы
06.06.2022 23:25

Составьте программу для решения задачи Пользователь вводит число х. Если введенное число больше или равно 5, то вывести на экран число х, увеличенное в 2 раза, если введенное число меньше 5, то вывести на экран это число без изменения

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
DashaSi15
02.04.2021 13:55

похоже на условный оператор if. Однако в случае циклических операторов их тела могут выполняться далеко не один раз. В случае if, если логическое выражение в заголовке возвращает истину, то тело выполняется единожды. После этого поток выполнения программы возвращается в основную ветку и выполняет следующие выражения, расположенные ниже всей конструкции условного оператора.

В случае while, после того как его тело выполнено, поток возвращается к заголовку цикла и снова проверяет условие. Если логическое выражение возвращает истину, то тело снова выполняется. Потом снова возвращаемся к заголовку и так далее.

Цикл завершает свою работу только тогда, когда логическое выражение в заголовке возвращает ложь, то есть условие выполнения цикла больше не соблюдается. После этого поток выполнения перемещается к выражениям, расположенным ниже всего цикла. Говорят, "происходит выход из цикла".

0,0(0 оценок)
Ответ:
tomchakd
02.04.2021 13:55

Python:

x = int(input())

if x >=5:

   print(x*2)

else:

   print(x)

Pascal:

var x: integer;

begin

 readln(x);

 if x >= 5 then

   writeln(x * 2)

 else

   writeln(x);

end.

Кумир:

алг

нач

   цел х

   ввод х

   если х >= 5 то

       вывод х*2

   иначе

       вывод х

   все

кон


Составьте программу для решения задачи Пользователь вводит число х. Если введенное число больше или
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота