au20941
20.03.2022 03:42

Написать программу, которая подсчитывает количество четных индексов положительных элементов введенного с клавиатуры массива целых чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
xgvhhdhs
17.06.2020 20:23

var

  a:array [1..100] of integer;

  i,n,k:integer;

begin

  write ('Razmer massiva: ');readln(n);

  k:=0; 

  for i:=1 to n do begin

    write ('A[',i,'] = ');readln(a[i]);

    if (a[i]>0) and (i mod 2 = 0) then k:=k+1;

  end;

  writeln ('Kol-vo: ',k);

  readln;

end.

0,0(0 оценок)
Ответ:
дизззи
17.06.2020 20:23

a - массив из n элементов
k - количество четных индексов положительных элементов
i - цикловая переменная, также индекс элемента массива
Язык программирования: Паскаль

var
a : array [1..100] of integer;
n, k, i : integer;
begin
k := 0;
readln (n);
for i:=1 to n do
begin
readln (a [ i ]);
if (i mod 2 = 0) and (a [ i ] > 0) then
k := k + 1;
end;
writeln (k);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота