amir45
16.07.2020 06:28

Написать программу в паскале. за ранее . на одномерный массив. 2. задан одномерный массив mas2 [1..10]. массив объявите как константу типа integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99) замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте. результат вывести на экран. вычислить сумму всех элементов нового массива и вывести на экран. исходный массив новый массив -7 -14 89 7921 64 4096 -43 -86 4 16 6 36 8 64 -12 -24 55 3025 99 9801 сумма элементов нового массива 24835

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sophie9649
01.10.2020 07:00


Program Denisqaa;
uses crt;
const mas2:array[1..10] of integer=(-7, 89, 64, -43, 4, 6, 8, -12, 55, 99);
var
  res: array[1..10] of integer;
  i,sum:integer;
begin
  writeln('++');
  writeln('|            ПРОГРАММА  Denisqaa          |');
  writeln('++');
  writeln('|   Исходный массив   |   Новый массив    |');
  writeln('++');
  sum:=0;
  for i:=1 to 10 do
    begin
      if mas2[i]<0 then res[i]:=mas2[i]*2;
      if mas2[i]>0 then res[i]:=mas2[i]*mas2[i];
      if mas2[i]=0 then res[i]:=mas2[i];  
      sum:=sum+res[i];
      writeln('|    ',mas2[i]:8,'         |    ',res[i]:8,'       | ');
      writeln('++');
    end;
  writeln();
  writeln('Сумма элементов нового массива ',sum)
end.

0,0(0 оценок)
Ответ:
NShott17
01.10.2020 07:00

uses crt;
const
  a: array [1..10] of integer=(-7, 89, 64, -43, 4, 6, 8, -12, 55, 99);
var
  b:array[1..10] of integer; i,s:integer;
begin

  s:=0;
  writeln('Исходный массив');
  for i:=1 to 10 do
  begin
    write(a[i]:5);
    if a[i]>0 then b[i]:=sqr(a[i])
      else b[i]:=2*a[i];
  end;
  writeln;
  writeln('Новый массив');
  for i:=1 to 10 do
  begin
    write(b[i]:5);
    s:=s+b[i];
  end;
  writeln;

  writeln('Сумма элементов нового массива  ',s);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота