Арчи171
30.04.2022 09:23

12. определите значение переменной c после выполнения фрагмента программы: a: = 60; b: = 10; a: = a - b*3; if a 13. используя следующие фрагменты составьте оператор цикла с условием. а) a: =c+1; г) then; б) for; д) do; в) a> b; е) while. 14.в каком из условных операторов допущена ошибка? а) if a б) if a> b then max: =a; else max: =b; в) if b=0 then write (‘деление невозможно’); 15.определите значения переменной s после выполнения фрагмента алгоритма: а) на «4» s: = 0; m: =6: for i: =3 to m do s: =s+i; б) на «5» s: =0; i: =5; while i> 0 do begin i: =i-1; s: =s+i; end;

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vika2074
04.03.2020 04:20
)

Romanova = 82 111 109 97 110 111 118 97 (не забываем пробелы)

Но! Это десятичная форма, а нам нужна двоичная! Поэтому:

Заходим в калькулятор -> Вид -> Программист. (Слева, среди английских надписей нужно выбрать "Dec")

Теперь вводим в этот калькулятор десятичный код = (например) 82. И среди английских записей меняем "Dec" на "Bin".

Получаем двоичный код ОДНОЙ буквы. R = 82 = 1010010 (Когда будете переписывать, то добавьте к полученному двоичному коду впереди ноль. Потому что этот код должен состоять из 8 цифр, просто калькулятор этого не понимает)

Проделываем ту же операцию со всеми буквами вашей фамилии (сначала в десятичную форму ANSI, потом в двоичную, при калькулятора)

2. Ну тут можно использовать тот же метод кодировки ANSI.

Пишем русскую фразу, потом находим все эти буквы в таблице ANSI и так далее.

Надеюсь


Закодируйте в двоичной форме свою фамилию, записанную латинскими буквами, используя таблицу кодировк
0,0(0 оценок)
Ответ:
jgjgjgjh
04.03.2020 04:20

Romanovich (первая буква большая)

Кодирование в ASCII (American standard code for information interchange):

Двоичный код: 01010010 (R), 01101111 (o), 01101101 (m), 01100001 (a), 01101110 (n), 01101111 (o), 01110110 (v), 01101001 (i), 01100011 (c), 01101000(h)

Кодирование в КОИ-8 («Код Обмена Информацией 8-битовый», таблица разработана для кодирования букв кириллицы)

Двоичный код: 11111010 (З), 11000001 (а), 11010111 (в), 11010100 (т), 11010010 (р), 11000001 (а), 00100000 (пробел), 11010111 (з), 11001001 (и), 11001101 (м), 11000001 (а), 00101110 (. точка)

Десятичный код этой фразы: 250, 193, 215, 212, 210, 193, 32, 215, 201, 205, 193, 46

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота