Lasosь
26.03.2022 22:32

Напишите программу, которая посчитает сумму всех чисел от 107 до 205 включительно ответ: (penalty regime: 10%, 20%, ...%)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
banana92
27.04.2023 09:07
Условие в вопросе и комментариях различается, поэтому приведу два варианта.
1) Программа выводит элементы с четными номерами(те, которые стоят в массиве на четных местах)

Program n1;
const n=10;
var a: array[1..n] of integer;
i: integer;
begin
writeln('Введите массив в одну строку через пробел:');
for i:=1 to n do read(a[i]);
writeln('элементы с четным номером:');
for i:=1 to n do if i mod 2=0 then write(a[i],' ');
end.

2) Программа выводит четные элементы массива

Program n1;
const n=10;
var a: array[1..n] of integer;
i: integer;
begin
writeln('Введите массив в одну строку через пробел:');
for i:=1 to n do read(a[i]);
writeln('четные элементы:');
for i:=1 to n do if a[i] mod 2=0 then write(a[i],' ');
end.
0,0(0 оценок)
Ответ:
zhelavskaitanya
09.04.2022 06:33

#include <iostream>

#include <time.h>

using namespace std;

int main()

{

 setlocale(LC_ALL, "Russian");

 int a[5][5];

 int i, j, s, p;

 srand(time(NULL));

 for (i = 0; i <= 4; i++) {

   cout << "\n";

   for (j = 0; j <= 4; j++) {

     a[i][j] = ((double)rand() / (RAND_MAX + 1) * 5) + 1;

     cout << a[i][j] << ' ';

   }

 }

 s = 0;

 for (i = 0, j = 4; i < 5; i++, j--)  // правая диагональ

   s += a[i][j];

 p = 1;

 for (i = 0; i < 5; i++)        // левая диагональ

   p *= a[i][i];

 cout << "\n\nСумма правой диагонали = " << s << "\nПроизведение левой диагонали = " << p << "\n";

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота