zaj2015
25.05.2021 17:07

Вмассиве из 10 вещественных чисел вычислить среднее арифметическое массива, стоящих левее максимального. составить программу на языке паскаль. надо.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Elli34
01.10.2020 06:58

uses crt;
var
  a:array [1..10] of integer;
  i,max,k,n:integer; sr:real;
begin
  clrscr; randomize;

  writeln('Массив:');
  for i:=1 to 10 do
  begin
    a[i]:=random(100);
    write(a[i],' ');
  end;
  writeln;
  max:=a[1];
  for i:=1 to 10 do
    if a[i]>max then
    begin
      max:=a[i];
      n:=i;
    end;
  writeln('Максимальный элемент массива: ',max);
  for n:=n+1 to 10 do
  begin
    sr:=sr+a[n];
    k:=k+1;
  end;
  write('Среднее чисел, стоящих левее максимального: ',(sr/k));
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота