Pakimon4ikYT
18.11.2021 09:51

дам50 былов 1.Определите значение выражения на языке Python 9//5 *
4
1
1,8

2.Определите значение выражения на языке Python 9%5 *
1,8
4
1

3.Определите значение выражения на языке Python 9//5+9%5 *
5
1
3,6

4.Каким будет результат выполнения программы numbers = [2, 6, 4, 3, 6, 8, 9] print (len(4)) *
9,8,6,6,4,6,2
2,6,3,4,6,8,9
2,6,3,6,8,9

5.Что называется массивом? *
под массивом понимается совокупность бесконечного числа данных одного типа
под массивом понимается совокупность конечного числа данных одного типа
под массивом понимается совокупность конечного числа данных различных типов

6.Укажите правильное описание массива *
var A: ARRAY[1...50 OF REAL]
Var A,B, C: ARRAY[1...50 OF REAL] OR INTEGER
Var a: array[1...1000] of integer

7.Числовой массив А заполнен последовательно числами: 7,15,87,34. Укажите значение элемента А[2] *
7
15
87
34
8.Какая команда заполняет массив с клавиатуры? *
ROUND
Random(s)
Read(A[і])

9.Что производит следующий фрагмент программы for i;=1 to n do write(a[i],' ') *
ввод элементов массива из файла
вывод элементов массива на экран монитора
ввод элементов массива склавиатуры

10,Что производит следующий фрагмент программы randomize; write('число элементов'); readln(n); for i:=1 to n do begin a[i]:=random(45)-22; end; write(n) *
заполняет массив одинаковыми числами и выводит их на экран
заполняет массив случайными числами и выводит их на экран
заполняет массив случайными числами и не выводит их на экран

Это обязательный вопрос.

11.Каким будет результат выполнения программы a=8 if a>2: print (“two”) if a>10: print (“ten”) *
0
two
ten

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shcoll15
12.10.2020 14:05
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var m,n:integer;
  Write('Количество строк и столбцов матрицы: ');
  Read(n,m);
  var a:=MatrixRandom(n,m,10,99);
  for var i:=0 to n-1 do begin
    for var j:=0 to m-1 do Print(a[i,j]);
    Writeln
    end;
  var p:=ReadInteger('Введите число Р:');
  var b:array of integer;
  SetLength(b,4*m);
  var k:=0;
  for var i:=n-p to n-1 do
    for var j:=0 to m-1 do
      if a[i,j] mod 4=0 then begin
        b[k]:=a[i,j]; Inc(k)
        end;
  SetLength(b,k);
  b.Print
end.

Тестовое решение:
Количество строк и столбцов матрицы: 6 8
67 70 68 72 38 72 96 38
49 75 24 55 72 63 21 40
72 12 60 22 74 30 13 45
22 45 39 24 35 97 64 31
76 62 15 94 56 28 31 13
41 67 75 37 67 13 25 20
Введите число Р: 4
72 12 60 24 64 76 56 28 20
0,0(0 оценок)
Ответ:
ivanperepelkin
11.01.2020 11:24
#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;

int main()
{
vector<int> v;
cout <<"Укажите размер массива: ";
int s;
cin >>s;
srand(time(0));
for(int i=0; i!=s; ++i)
v.push_back(rand()%100);
int find;
cout <<"Введите число для поиска: ";
cin >>find;
bool founded = false;
for(auto it=v.begin(); it!=v.end(); ++it)
if(*it==find) founded=true;
if(founded)
cout <<"Это число есть в массиве!" <<endl;
else cout <<"Такого числа нет в мвссиве!" <<endl;

return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота