007ek
29.10.2021 02:41

Напишите программу, которая выводит значения функции y=kx+b на интервале [2,8] с шагом 1. Программу можно писать на компьютере так и в тетраде.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ghhgfgh
26.04.2021 01:14
// PascalABC.Net

function IsNice(n:longint):boolean;
// Отвечает на вопрос, является ли число красивым
var
  d,nd,sd:byte;
begin
  sd:=0; nd:=0;
  repeat
    d:=n mod 10;
    sd:=sd+d; Inc(nd);
    n:=n div 10
  until n=0;
  IsNice:=(sd mod nd = 0)
end;

var
  i,n,k:longint;
begin
  Write('Порядковый номер "красивого" числа: '); Read(n);
  i:=1; k:=0;
  repeat
    if IsNice(i) then Inc(k);
    if k<>n then Inc(i)
  until k=n;
  Writeln('Красивое число равно ',i)
end.

Тестовое решение:
Порядковый номер "красивого" числа: 15
Красивое число равно 20
0,0(0 оценок)
Ответ:
Котанская
26.04.2021 01:14

Можно так

a = int(input())

if ((a // 100) + (a % 10)) / 2 == ((a // 10) % 10):

   print("Вы ввели красивое число")

elif ((a // 100) + (a // 10) % 10) / 2 == (a % 10):

   print("Вы ввели красивое число")

elif ((a % 10) + ((a // 10) % 10)) / 2 == (a // 100):

   print("Вы ввели красивое число")

else:

   print("Жаль, вы ввели обычное число")

НО ЕСЛИ ТЫ НЕ ПОНЯЛ КОД ТО:

answer1 = input()

if (int(answer1[0]) == int(answer1[1]) and int(answer1[0]) != int(answer1[2])):

   print("Жаль, вы ввели обычное число")

elif(int(answer1[0]) == int(answer1[1]) == int(answer1[2])):

   print("Вы ввели красивое число")

elif (answer1[0]) != int(answer1[1]) == int(answer1[2]):

   print("Жаль, вы ввели обычное число")

elif (answer1[0]) != int(answer1[1]) == int(answer1[2]):

   print("Жаль, вы ввели обычное число")

Эта только первая часть

Смотри коментарии

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота