SnowWhite98
29.09.2020 18:33

Задание 2

Оператор выбора. Составить программу, которая спрашивает у детей возраст и распределяет их по группам в детском садике. Если ребёнку 1-2 года, то в группу "ясли"; если 3-4 года, то в "младшую" группу; если 5 лет, то в "старшая"; если 6 лет - "подготовительная". Если введён другой возраст, то выдать сообщение «Это не возраст для приема в садик!».

Задание 3
Циклический оператор. Составить программу, которая выводит на экран для числа 3 ее степени от 1 до 6.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vika3499
03.01.2023 20:41

В sql еще есть команда UNIQUE тоже задает свойства по умолчанию

Задание значения по умолчанию

В области навигации щелкните правой кнопкой мыши таблицу, которую вы хотите изменить, и выберите команду Конструктор.

Выберите поле, которое требуется изменить.

На вкладке Общие введите значение в поле свойства Значение по умолчанию.

Значение, которое можно ввести, зависит от типа данных, заданного для поля. Например, в поле "Дата/время" можно ввести =Date() для вставки текущей даты.

Задание значения по умолчанию для элемента управления

Обычно значение по умолчанию задается для элемента управления только в том случае, если он не привязан к полю таблицы или же связан с данными из другой таблицы.

Задание строки по умолчанию для списка или поля со списком

По умолчанию в списках и полях со списком отображаются два типа списков: списки значений и списки подстановки. Список значений — это жестко заданный список элементов, который хранится в свойстве Источник строк списка или поля со списком. С другой стороны, список подстановки берет данные из поля подстановки (поля, которое использует запрос для получения данных из другой таблицы), а затем загружает их в поле со списком.

Для списков значений и списков подстановки можно указать, какой элемент должен отображаться по умолчанию, но процедуры для каждого типа списка различаются. Ниже описано, как задать значения по умолчанию для списка значений и списка подстановки.

Задание значения по умолчанию для списка значений

В области навигации щелкните правой кнопкой мыши форму, которую вы хотите изменить, и выберите команду Конструктор.

Щелкните правой кнопкой мыши список или текстовое поле и выберите пункт Свойства или нажмите клавишу F4.

Убедитесь, что свойство Источник строк содержит список значений. Элементы списка значений заключено в двойные кавычки и через точку с запятой. Например, вы видите список следующим образом: " "хорошая «;» Ярмарки»;» Низкое"".

Если свойство Источник строк содержит запрос (строку текста, которая начинается с SELECT), перейдите к следующей последовательности шагов.

В поле свойства Значение по умолчанию введите следующее:

[control_name]. ItemData (n)

В этом случае элемент_управления — это имя списка или поля со списком, а n — это номер элемента списка, который нужно выводить по умолчанию. Если вы не знаете имя элемента управления, просмотрите значение свойства Имя в верхней части страницы свойств.

Предположим, например, что у вас есть поле со списком Владелец и вы хотите по умолчанию использовать его третье значение. В поле свойства Значение по умолчанию введите следующее:

[Владелец].ItemData(2)

Нужно ввести 2 вместо 3, так как нумерация ItemData начинается с нуля, а не с единицы.

Сохраните изменения и переключитесь в режим формы. Выбранное значение по умолчанию будет выводиться в списке или поле со списком при добавлении записи в базу данных.

0,0(0 оценок)
Ответ:
Книжнаябабочка
11.01.2021 20:57

1)

amount = 0

for i in range(1, 51):

   if (i % 2 == 0):

       amount += i

print(amount)

2)

from random import randint

lst = [randint(1, 100) for i in range(10)]

print(lst)

for i in range(len(lst)):

   lst[i] //= 2

print(lst)

Объяснение:

Парные числа - числа, которые делятся на 2 без остатка.

1)

amount = 0 // Переменная, хранящая сумму, равна нулю

for i in range(1, 51): // Берём элементы от 1 до 50 (первые 50 натуральных чисел)

   if (i % 2 == 0): // Если число делится на 2 без остатка

       amount += i // Сумма = сумма + i

print(amount) // Вывод ответа

2)

from random import randint // импорт функции randint() из библиотеки random

lst = [randint(1, 100) for i in range(10)] // Создание списка из рандомных чисел в диапазоне [1..100], состоящего из 10 элементов.

print(lst) // Выводим список

for i in range(len(lst)): // Берём индексы каждого элемента списка

   lst[i] //= 2 // Делим значение списка с индексом i на 2

print(lst) // Выводим список

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота