emdnick
18.02.2021 09:30

Паскаль! Даны действительные числа х и у.
Результат округлить до 2-х знаков после запятой
Данные для самопроверки:
Введите переменную х -25
Введите переменную у 6.5
Результат 0.11
Получить


Паскаль! Даны действительные числа х и у. Результат округлить до 2-х знаков после запятой Данные дл

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nog2018
11.12.2020 01:59
Язык C++.
1. #include <iostream>
using namespace std;
int main() {
    int i;
    cout <<"Введите число: " << endl;
    cin >> i;
    cout << "Вы ввели число: " << i << endl;
    }

2. #include <iostream>
using namespace std;
int main (){
    int i;
    cout << "Vvod" << endl;
    cin >> i;
    i %= 10;
    if(i %2 != 0)
    cout << "Нечетная" << endl;
    else
    cout << "Четная" << endl;
    }

3. #include<iostream>
using namespace std;
int main (){
for(int k = 0; k<4; k++){
cout << "random number = " << rand() << endl;
}
}

4. #include <iostream>
using namespace std;
int main(){
int i,a,b,c;
cin >> i;
c = i%10;
b =(i/10)%10;
a = i/100;
if(i*i==a*a*a+b*b*b+c*c*c)
cout<<"Является."<<endl;
else 
cout<<"Не является."<<endl;
}

5. #include <iostream>
#include <cmath>
const double pi = 3.1415926536;
using namespace std;
int main(){
    float x = 0;    cout << "Введите x: " << endl;
    cin >> x;
    cout << "y = " <<  sin((pi*(3.2+(sqrt(1+x))))/180)/abs(5*x) << endl;
    }

Добавляем "pi" и делим на 180, чтобы "sin" был в градусах.

Блок-схемы смотри во вложении.
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
1. написать программу и составить к программе блок-схему. составить программу вывода на экран числа,
0,0(0 оценок)
Ответ:
vitusyaischuk
15.10.2021 14:21

Задача 1

Program Zadanie1;

var i,N:integer;

A:array[1..4]of integer;

Begin

readln(n);

A[1]:=round(int(N/1000));

A[2]:=round(int(N/100))-A[1];

A[3]:=round(int(N/10))-A[1]-A[2];

A[4]:=N-A[1]-A[2]-A[3];

if (A[1]:=A[4]) and (A[2]:=A[3]) and (A[3]:=A[2]) and (A[4]=A[1]) then writeln('полином');

end;

 

Задача 2

Program Zadanie2;

var i,N:integer;

A:array[1..3]of integer;

 

function Kub(a):integer;begin Kub:=a*a*a;end;

 

Begin

readln(n);

A[1]:=round(int(N/1000));

A[2]:=round(int(N/100))-A[1];

A[3]:=N-A[1]-A[2]-A[3];

if N*N=kub(A[1])+kub(A[2])+kub(A[3]) then writeln('равенство');

end;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота