kagger07
26.09.2021 14:42

Составить программу вычисления Y по заданному X. На Паскаль 7 класс​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gebatible777
12.08.2021 16:53
В прямоугольном треугольнике должна выполняться теорема Пифагора. Найдем самую длинную строну и проверим, является ли квадрат ее длины суммой квадратов длин двух других сторон. Для того, чтобы избежать ошибок округления примем, что все длины - натуральные числа.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите через пробел или Enter стороны:');
  if a>c then Swap(a,c);
  if b>c then Swap(b,c);
  if c*c=a*a+b*b then Writeln('Треугольник прямоугольный')
  else Writeln('Треугольник не прямоугольный')
end.

Пример
Введите через пробел или Enter стороны: 6 8 10
Треугольник прямоугольный
0,0(0 оценок)
Ответ:
Іруна
17.01.2022 21:31
1) Работает 6 часов по полчаса - 12 пациентов. Кодируется int(log2 12) = 4 битами. 2) 32 буквы кодируются 5 битами (log2 32). В слове «муравей» 6 букв. 6 * 5 = 30.3) 8*8 = 64. log2 64 = 6. Именно столько бит необходимо для кодирования каждой клетки.4) Что подразумевается под «оптимальным» не знаю, так что затрудняюсь ответить.5) log2 64 = 6 - количество бит для кодирования символа. 2000 * 6 = 12000 - количество бит для кодирования текста. 12000 / 8 = 1500 - количество байт для кодирования текста.6) 300 / 150 = 2 байта на символ. 2 * 8 = 16 бит. 2^16 = 65536. В алфавите не более 65536 символов7) Если кодировка ASCII или другая с кодированием в 1 байт на символ, то да, т.к. в килобайте 1024 байт. Если Unicode или подобные с 2-байтовой кодировкой, то нет/8) 5000 / 10 = 500 - байт  = 4000 бит в секунду. 800 - символов в секунду. 5 бит на символ. 2^5 = 32 символа9) 2,5 = log2 32 / log2 x. Получаем, что x = 410) один 8-ричный разряд содержит 3 бита (log2 8), 3 разряда числа - 3 * 3 = 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота