Yasmin76000
28.07.2020 11:38

Составьте программу, вычисляющую произведение элементов двумерного массива размером


Составьте программу, вычисляющую произведение элементов двумерного массива размером

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Abibkaa
07.10.2022 06:11
#include <cstdlib>
#include <iostream>
#include <cmath>
using namespace std;

int main() {
   float a,b,c,p,s;
   struct   {
           float ax,ay,bx,by,cx,cy;
     } ABC;
   cout<<" задайте координаты точек"<<endl;
   cout<<" ax "<<" ay "<<" bx "<<" by "<<" cx "<<" cy";
   cout<<endl;
   cin>>ABC.ax>>ABC.ay>>ABC.bx>>ABC.by>>ABC.cx>>ABC.cy;
// вычисление длин сторон
   a=sqrt(pow((ABC.bx-ABC.ax),2)+pow((ABC.by-ABC.ay),2));
   b=sqrt(pow((ABC.cx-ABC.bx),2)+pow((ABC.cy-ABC.by),2));
   c=sqrt(pow((ABC.cx-ABC.ax),2)+pow((ABC.cy-ABC.ay),2));
   p=(a+b+c)/2;
// проверка, что можно составить треугольник
   if (((p-a)>0) && ((p-b)>0) && ((p-c)>0))
   cout<<"точки образуют треугольник"<<endl;
   else  cout<<"точки лежат на одной прямой"<<endl;

   system("pause");
   return(0);
}
0,0(0 оценок)
Ответ:
mhjkglckktcfcmjkfg
13.09.2020 17:36
Program abc;
var a:array[1..6] of integer;
var i,s: integer;
begin
 i:=0;a[1]:=500;a[2]:=100;a[3]:=10;a[4]:=5;a[5]:=2;a[6]:=1;
writeln('Введите целое число,сумму денег:');
readln(s);
while s<>0 do
begin
if s>=a[1] then begin
s:=s-a[1]; i:=i+1; end;
if (s>=a[2]) and (s<a[1]) then begin s:=s-a[2]; i:=i+1; end;
if (s>=a[3]) and (s<a[2]) then begin s:=s-a[3]; i:=i+1; end;
if (s>=a[4]) and (s<a[3]) then begin s:=s-a[4]; i:=i+1; end;
if (s>=a[5]) and (s<a[4]) then begin s:=s-a[5]; i:=i+1; end;
if (s>=a[6]) and (s<a[5]) then begin s:=s-a[6]; i:=i+1; end; 
end;
Writeln('Наименьшее число купюр =',i);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота