leovd
08.08.2021 00:14

Задание 1 ( ). Приведите общую характеристику языка Паскаль. Какова структура программы на Паскале?

Задание 2 ( ).

Составить блок-схему алгоритма и программу на Паскале для вычисления функций z. Ввести программу в Паскале, вычислить значения функции и проверить ее для самостоятельно выбранных трех пар значений переменных X и Y.
28.png

Задание 3 ( ).

Составить блок-схему алгоритма и программу для обработки массива из 20 чисел X=(0,3;5;68;-3;32;-80;-9;-26;-9;40;36;13;15;28;-0,7;-36;-0,3;8;15;-7) при b=5. Вычислить произведение и количество элементов, не равных нулю и меньших b.

Задание 4 ( ).

Составить программу и блок-схему для вычисления суммы площадей всех квадратов, стороны которых изменяются в цикле от 1 до 10. В отчет включить тексты программ на Паскале, результаты работы в виде скриншотов окна программы с отображением кодов и результатов работы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Tashkentskiy
07.11.2020 11:35
Program  Ilgiz98;
var
  i: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Программа находит 4-значные числа, которые делятся на 27');
  writeln('Список таких чисел:');
  for i:=1000 to 9999 do
    if (i mod 27)=0 then writeln(i);
end.

Program  Ilgiz98;
var
  mass: array [1..20] of integer;
  i, k, n: integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln('Среди элементов массива программа находит числа, которые больше заданного числа N и одновременно кратны 5');
  write('Введите число N ');  readln (n);
  writeln('*** Вычисляю... ***');
  k:=0;
  writeln('Массив чисел:');
  for i:=1 to 20 do
    begin
     mass[i]:=random(1000)-500;
     writeln(mass[i]);
     if (mass[i]>n) and ((mass[i] mod 5)=0) then k:=k+1;
  end;
  writeln();
  writeln('Всего найдено ',k,' таких чисел');
end.
0,0(0 оценок)
Ответ:
Messidarcelona05
03.05.2020 18:45
Задача 1
var
s: string;
i: integer;
begin
readln(s);
for i:=2 to length(s)-2 do
 if (s[i-1]+s[i]+s[i+1]+s[i+2]=' не ') then s[i+1]:='и'
  else if ((s[i-1]+s[i]+s[i+1]='не ') and (i=2)) then s[i]:='и'
   else if ((s[i]+s[i+1]+s[i+2]=' не') and (i=length(s)-2)) then s[i+2]:='и';
write(s);
end.

Задача 2
var
s: string;
i, k: integer;
begin
readln(s);
for i:=2 to length(s)-1 do
 if s[i-1]+s[i]+s[i+1]=' в ' then inc(k)
  else if ((s[i-1]+s[i]='В ') or (s[i-1]+s[i]='в ')) and (i=2) then inc(k);
write(k);
end.

Если есть вопросы, пишите в ЛС :)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота