89109301839
22.11.2020 02:42

ПИТОН! Условие
С клавиатуры водится два целых числа: КиN - это индексы элементов, которые нужно
поменять местами в исходном списке вещественных чисел.
Если в списке нет элемента с указанным индексом, выведите на экран "Ошибка!", если оба
индекса существуют в списке, то выведите исправленный список.
Формат входных данных
Вводится два целых числа, каждое в отдельной строке: КиN.
Далее вводится список вещественных чисел. Вводится одной строкой, все числа через пробел.
Формат выходных данных
Исправленный список или текст: "Ошибка!".
Входные данные
0
1
1.5 1.6 3.4 6.8
Выходные данные
6.7 1.5 3.4 6.8

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
chcuvivhcyxu
09.02.2020 08:29
Червь  – программа, которая делает копии самой себя. Ее вред заключается в захламлении компьютера, из-за чего он начинает работать медленнее. Отличительной особенностью червя является то, что он не может стать частью другой безвредной программы.Троянская программа (троянский конь, троян)Троянская программа маскируется в других безвредных программах. До того момента как пользователь не запустит эту самую безвредную программу,  троян не несет никакой опасности. Тронская программа может нанести различный ущерб для компьютера. В основном трояны используются для кражи, изменения или удаления данных. Отличительной особенностью трояна является то, что  он не может самостоятельно размножаться.
0,0(0 оценок)
Ответ:
gg228
18.11.2021 12:00
Program q1;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of integer;
countNum:integer; // переменная для хранения количества нечетных чисел
proizv:integer; // переменная для хранения произведения нечетных чисел
BEGIN
proizv:=1; // так как, изначально равно 0, а при умножении на 0 будет всегда 0
{создание последовательности n целых чисел}
Writeln('Случайные целые числа: ');
for i:=1 to n do
begin
mass[ i ]:=random(9)+1; //присваеваем переменной случайное значение от 1 до 10
write(inttostr(mass[ i ])+', ');
end;
{Вычисление произведения и количества нечетных чисел}
for i:=1 to n do
if mass[ i ] mod 2 <> 0 then //проверяем не четное-ли число, если да, то.. .
begin
inc(countNum); //увеличиваем на один кол-во нечетных чисел
proizv:=proizv*mass[ i ]; // высчитываем произведение
end;
{Вывод результатов}
writeln;
writeln('Всего нечетных чисел: '+inttostr(countNum));
writeln('Их произведение: '+inttostr(proizv));
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота