Sultanika
17.05.2021 11:33

Решить задачу. Написать программу, которая запрашивает массив из N целых чисел, а затем выводит порядковые номера нулевых элементов массива или сообщение «Нет таких элементов».​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Artemka1337w
16.11.2022 02:02
Pascal:
var n,a,s:longint;
begin
  repeat
    write ('N = ');
    readln(n);
  until n in [10..99];
  write ('A = ');
  readln(a);
  s:=0;
  while n<>0 do
    begin
       s:=s+n mod 10;
       n:=n div 10;
    end;
  if s>a then writeln ('YES') else writeln ('NO');
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
   int a,n,s = 0;
   do
   {
      cout <<"N = ";
      cin >>n;
   }
   while (n<10 || n>99);
   cout <<"A = ";
   cin >>a;
   while (n!=0)
   {
     s+=n%10;
     n/=10;
   }
   if (s>a)
      cout <<"YES" <<endl;
   else cout <<"NO" <<endl;
   return 0;
}
0,0(0 оценок)
Ответ:
istepysh
16.11.2022 02:02
// PascalABC.NET 3.1, сборка 1179 от 29.02.2016
procedure GetProdNeg(a:array of integer; var p:real);
// произведение отрицательных элементов
begin
  p:=a.Where(x->x<0).Aggregate(1.0,(p,e)->p*e)
end;

function IsPrime(n:integer):boolean:=
  Range(2,Round(sqrt(n))).All(i->n mod i<>0);

procedure ArrPrime(n:integer; var a:array of integer);
// массив простых чисел не больших n
begin
  a:=Range(2,n).Where(i->IsPrime(i)).ToArray
end;

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50); a.Println;
  var r:real;
  GetProdNeg(a,r);
  Writeln('Произведение ',r);
  n:=ReadInteger('n=');
  var b:array of integer;
  ArrPrime(n,b);
  b.Println
end.

Тестовое решение:
n= 15
27 -7 -36 40 -15 -21 -47 -28 -12 45 3 -38 -15 1 -39
Произведение 27866837980800
n= 300
2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149 151 157 163 167 173 179 181 191 193 197 199 211 223 227 229 233 239 241 251 257 263 269 271 277 281 283 293
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота