MarrySen
06.07.2020 18:26

Язык Pascal. Напишите программу, которая позволяет вводить с клавиатуры натуральное четырехзначное число а и определяет сумму и произведение его цифр. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ma4newarita
08.06.2020 18:35
Вот оттестированный мой вариант программы. Тестировал на числах от 1 до 6. Писать начал чуть раньше Антагониста, но он оказался шустрее :))

//PascalABC
//NaaMan
//Программа расчитана ТОЛЬКО на факториалы
//Проверки ошибочного ввода НЕТ
var n, result, i : real;
begin
    write('Введите факториал > ');
    readln(n);
    if (n = 1) then
        result := 1
    else begin
        i := 2;
        while n <> 1 do begin
            n := n / i;
            result := i;
            i := i + 1;
        end;
    end;
    writeln('Число ', result);
end.

В! много ! 9 8) известен факториал числа n. найти это число. 15) начав тренировки, лыжник в первый д
В! много ! 9 8) известен факториал числа n. найти это число. 15) начав тренировки, лыжник в первый д
В! много ! 9 8) известен факториал числа n. найти это число. 15) начав тренировки, лыжник в первый д
0,0(0 оценок)
Ответ:
farita1
16.02.2020 15:41
# coding: utf-8
# Python 3.X

'''
Вводятся четыре числа:
xa, ya: координаты ферзя
xb, yb: координаты другой фигуры

Координаты - целые числа
в интервале от 1 до 8.

Вывод - булево значение:
сможет ли ферзь побить фигуру
за 1 ход.
'''
def hits(xa, ya, xb, yb) -> bool:
    '''
    Проверка аргументов.
    '''
    args = (xa, ya, xb, yb)
    if any([not 1 <= z <= 8 for z in args]):
        raise ValueError("Неверные координаты!")

    '''
    На одной прямой.
    '''
    if xa == xb or ya == yb:
        return True

    '''
    Северо-западная диагональ.
    '''
    x_nw, y_nw = xa, ya
    while x_nw > 1 and y_nw > 1:
        x_nw -= 1
        y_nw -= 1
        if x_nw == xb and y_nw == yb:
            return True

    '''
    Юго-восточная диагональ.
    '''
    x_se, y_se = xa, ya
    while x_se < 8 and y_se < 8:
        x_se += 1
        y_se += 1
        if x_se == xb and y_se == yb:
            return True

    '''
    Юго-западная диагональ.
    '''
    x_sw, y_sw = xa, ya
    while x_sw > 1 and y_se < 8:
        x_sw -= 1
        y_sw += 1
        if x_sw == xb and y_sw == yb:
            return True

    '''
    Северо-восточная диагональ.
    '''
    x_ne, y_ne = xa, ya
    while x_ne < 8 and y_se > 1:
        x_ne += 1
        y_ne -= 1
        if x_ne == xb and y_ne == yb:
            return True

    return False # если не бьет

inp = [int(x) for x in input().split()]
if hits(*inp):
    print('YES')
else:
    print('NO')
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота