Cherry5858
26.09.2022 23:21

Составьте программу для нахождения суммы​


Составьте программу для нахождения суммы​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Акмарал252887
11.07.2022 07:39

1.

 

program simple;

var a,b:integer;

begin

 writeln('daite a, b); readln(a,b);

 writeln('x = ', b/a); readln;

end;

 

2.

 

program day;

var h,hours,minutes:longint;

begin

  writeln('daite secundi'); readln(h);

  hour:= h div 3600; minutes:=h mod 36000;

  if (minutes > 60) or (minutes=60) then 

   begin

     hour:=hour+1;

     minutes:=minutes-60;

  end;

  writeln('It is 'hours' hours 'minutes' minutes');

readln;

end;

 

3.

 

program summaChisla;

var s:string; i,sum: longint; c,cod:integer;

begin

  writeln('daite nomer); readln(s);

  for i:=1 to length(s) do

   begin

      val(s[i],c,cod); sum:=sum+c;

   end;

writeln('summa :',sum); readln;

end;

0,0(0 оценок)
Ответ:
DilulRi
24.09.2022 14:48

var a, b, c,d,e,f,g : integer;

begin

  for var i := 1 to 28 do begin

     readln(a);

     if a = 2 then b := b + 1

     else if a = 3 then c := c + 1

     else if a = 4 then d := d + 1

     else if a = 5 then e := e + 1;

     if i <= 14 then f := f + a

     else g := g + a;

  end;

  f := round(f / 14);

  g := round(g / 14);

  writeln('Число двоек : ',b);

  writeln('Число троек : ',c);

  writeln('Число четвёрок : ',d);

  writeln('Число пятёрок : ',e);

  writeln('Число двоек : ',a);

  writeln('Средний балл среди мальчиков : ', f);

  writeln('Средний балл среди девочек :', g);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота