DeNiSNoNs
12.05.2022 01:33

Напишите программу на Python.
"Найти количество четных цифр заданного натурального числа N."

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vova147228
27.02.2021 19:20

while True:

 try:

   n = int(input('Введите натуральное число: '))

   break

 except ValueError:

   print('Неверные входные данные. Попробуйте снова.')

n = abs(n)

b = 0

while n>0:

 if n%10%2 == 0:

   b+=1

 n = n//10

print('Количество чётных цифр в ведённом числе равно ' + str(b))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота