denasty
25.04.2021 10:07

Напишите программу, которая в последовательности натуральных чисел отделяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчиваюшееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число - сумму чисел, оканчивающихся на 4. Программа должна быть на паскале! Очень

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladgodd
26.02.2021 22:00

var n,i,a,min: integer;

begin

readln(n);

min := 30001;

for i := 1 to n do

begin

readln(a);

if (a mod 10 = 4) and (a < min)

then min := a;

end;

writeln(min)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота