kirillsokolov22
31.08.2020 02:59

Напишите программу для решения следующей задачи дано целое число является ли оно четным?(C++)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
лиз20031
26.02.2021 12:50

#include <iostream>

using namespace std;

int main(){

   int n;

   cin >> n;

   if ((n & 1) == 0)

       cout << "Четное";

   else

       cout << "Нечетное";

   return 0;

}

0,0(0 оценок)
Ответ:
NEON2006
26.02.2021 12:50

Код на C++:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   int n;

   cin >> n;

   cout << (n % 2 ? "Нечетное (Odd)" : "Четное (Even)") << endl;

   return 0;

}

Объяснение:

Элегантное и простое решение с использованием тернарного оператора

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота