Салатикус
04.03.2020 20:54

Написать программу ,которая выводит на экран таблицу умножения всех чисел(в виде квадрата пифагора).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Zakharova2007
17.06.2020 10:00

Program Pifagor;
uses crt;
const n=10;
var
  x,y:integer;
begin
  writeln('');
  writeln('*                        PIFAGOR                       *');
  writeln('*                  (таблица умножения)                 *');
  writeln('');
  write('*    * ');
  for y:=1 to n do
    begin
      write(y:2);
      if y<n then write(' | ')
      else      writeln(' * ');
    end;
  writeln('');
  for x:=1 to n do
    begin
      write('* ',x:2, ' * ');
      for y:=1 to n do
         begin
          write(x*y:2);
          if y<n then write(' | ')
        end;
        if x*y<100 then writeln(' * ')
                   else writeln('* ');
        if x<10 then writeln('++')
                else writeln('');
    end;
end.

0,0(0 оценок)
Ответ:
vanzoca
17.06.2020 10:00

Паскаль

 

uses crt;
var n,m:integer;
begin
  for n:=1 to 9 do
  begin
    for m:=1 to 9 do
      write(m*n:5);
    writeln;
  end;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота