SandruhA
28.05.2023 15:34

Напишите программу (на паскале) для нахождения наибольшего общего делителя для чисел 12, 24, 30, 48 и 51 с использованием процедуры​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dilnazka3
24.02.2021 19:20

var a,b: integer;

function NOD(x,y: integer): integer;

begin;

  if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;

end;

begin;

  readln(a,b);

  writeln( 'НОД= ', NOD(a,b) );

end.

Объяснение:begin(в переводе с английского начало)if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y(пишем этот код)end(в переводе с английского конец)Дальше пишем как я написал
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота