eevelinka742
28.06.2021 03:21

Написать программу определения минимального числа кратного 5, последовательности положительных чисел ( условие выхода отрицательное число или 0) Цикл repeat until ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
marissavyd
30.09.2022 17:26
1) на что мы используем Интернет (контакты, поиск информации для обучения, поиск инфы для жизни и т. д. ) 2) чем заменить все эти вещи без Инета (телефон и письма, учебники, и т. д.) 3) в чём разные хуже или лучше (напр, по телефону можно так же быстро поговорить, как и через Инет, но нельзя быстро переслать печатный текст. Бумажное письмо очень приятно писать и получать, но оно идёт слишком медленно, контакт по интернету самый быстрый, но немного теряется тепло живого общения) и так по всем пунктам. 4) большие области на нашей планете, где нет Инета или он плохой (медленный) и редко встречается (Африка). 5) в некоторых восточных странах Инет регулируется на государственном уровне (Китай, Корея) 5) вывод - в принципе, без Инета прожить можно, но во многих областях без него гораздо хуже и медленнее.
0,0(0 оценок)
Ответ:
veronikasabrin
22.03.2022 22:23
В программе буквы добавляются по алфавиту без повторений.
var s1,s2:string;
function F(var a,b:string):boolean;
var m:set of char; i:integer; c:char;
begin
 m:=[];
 for i:=1 to length(a) do
  if pos(a[i],b)=0 then m:=m+[a[i]];
 for c:=chr(32) to chr(255) do
  if c in m then a:=a+c;
 if m=[] then f:=false else f:=true;
end;
begin
writeln('Введите строку 1:');
readln(s1);
writeln('Введите строку 2:');
readln(s2);
if f(s1,s2)
 then writeln('Новая строка: ',s1) else writeln('Строка не изменилась ');end.

Пример:
Введите строку 1:
program
Введите строку 2:
procedure
Новая строка: programagm
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота