Makc134
31.12.2022 07:18

решить В паскале, буду очень благодарна 1. Рассмотрите предложенные фрагменты программ. Запишите, какой ответ будет выведен на экран после выполнения этот фрагмента: a:=15; b:=30; b:=a*2-b/2; if a>b then c:=3*b-a/3 else c:=3*a-4*b; write (a, b, c); 2.Рассмотрите предложенные фрагменты программ. Запишите, какой ответ будет выведен на экран после выполнения этот фрагмента: a:=5; b:=6; if b>5 then if a<5 then begin a:=a+4; b:=b-5 end else begin a:=a-3; b:=b+2 end else begin a:=b; b:=a+2 end; write (a, b); 3. Дано целое число А. Если значение А > 0, то необходимо увеличить его на единицу, иначе уменьшить на 2. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LedyKoshka
07.05.2023 06:58
Современный мир полон всяческих новинок: науки, техники, медицины. Никогда, наверное, люди не обладали такой суммой знаний в разных областях. Удивительные вещи и явления окружают нас.Наука придумала массу интересного и полезного. От биоматериалов до искусственной руки. От искусственной почки до контактных линз, которые тренируют ночью глазные мышцы.Технологии, созданные самими талантливыми людьми, могут приносить пользу, а могу т и вред. Смотря как ими пользоваться. С смартфона, например, можно разводить сплетни.ХАХАХХА сплетни)) Сам чЁ нибудь придумаешь хахаа
0,0(0 оценок)
Ответ:
nusikz
04.04.2023 19:20
1. Дискретность.  
Вы можете выполнить шаг только после выполнения предыдущего. Например, в алгоритме вычисления 8*3+2 (без скобок) вы сперва выполните умножение(по правилу), и только затем прибавите 2. Иначе ответ неверен.

2.Определенность.
Вы не можете разделить 8 на 3, если Вам ясно сказано: умножьте. Определенность - это четкое прописывание условия задачи.

3.Результативность.
После выполнения действий Вы получите ответ 26 и только 26. Результативность следует из определенности. Благодаря результативности Вы получите "среду", в которой все объекты однозначно определены.

4. Понятность.
(Здесь тоже нужно объяснить? По-моему, свойство само за себя говорит.)

5.Массовость.
Алгоритм может быть применен не единожды. То есть в нашем примере 8*3+2 присутствуют операции умножения и сложения, но они могут встречаться не только в нашем примере, а "пригодны" для множества других задач, в которых требуется умножить или сложить.

Надеюсь
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота