Tugoi
01.06.2022 08:24

1)     Напишите программу, которая запрашивает возраст школьника и определяет, в каком звене он обучается: начальная школа (1-4 классы), основная (5-9 классы) или старшая (10-11 классы). 2)     Напишите программу, которая запрашивает на ввод число. Если оно положительное, то на экран выводится цифра 1. Если число отрицательное, выводится -1. Если введенное число – это 0, то на экран выводится 0. Используйте в коде условный оператор множественного ветвления.
3)      Требуется перевести пятибалльную оценку в ее наименование: 5 — «отлично», 4 — «хорошо», 3 — «удовлетворительно», 2 — «неудовлетворительно».
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
timamirzoev
25.03.2021 21:21

N1

a = int(input())

if (a >= 7)&(a <= 10):

   print('начальная')

if (a >= 11)&(a <= 15):

   print('начальная')

if (a >= 16)&(a <= 17):

   print('начальная')

N2

a = int(input())

if a < 0:

   print(-1)

if a == 0:

   print(0)

if a > 0:

   print(1)

N3

a = ['неудовлетворительно','удовлетворительно','хорошо','отлично']

b = int(input())

print(a[b-2])

0,0(0 оценок)
Ответ:
koblovalv
25.03.2021 21:21

На Java:

1)

int x = new Scanner(System.in).nextInt(); //Вводим возраст

//7-10 - начальная школа

//11-15 - средняя школа

//16-17 - старшая школа

if (x >= 7 && x <= 10)

System.out.println("Начальная")

else if (x >= 11 && x <= 15)

System.out.println("Средняя")

else if (x == 16 || x == 17)

System.out.println("Старшая")

2)

int x = new Scanner(System.in).nextInt(); //Вводим число

if (x > 0)

System.out.println("1");

else if (x < 0)

System.out.println("-1");

else

System.out.println("0");

3)

int x = new Scanner(System.in).nextInt(); //Вводим оценку

switch(x) {

case 5:

System.out.println("отлично");

break;

case 4:

System.out.println("хорошо");

break;

case 3:

System.out.println("удовлетворительно");

break;

case 2:

System.out.println("неудовлетворительно");

}

Объяснение:

Всё это надо записать под отдельные функции, либо под главную исполняемую, чтобы вызвать глобально:

public static void main(String... arguments) {}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота