vvvvNikavvv
13.01.2022 11:09

до завтра надо Составьте программу рисования фигуры, изображенной на рисунке, таким образом, чтобы во время рисования перо не отрывалось от бумаги, и ни одна линия не проводилась дважды.

Кумир - Исполнитель Чертежник - Алгоритм рисования простой фигуры 9


до завтра надо Составьте программу рисования фигуры, изображенной на рисунке, таким образом, чтобы в

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KTTC28072003
29.12.2021 20:13

from random import randint

name_1 = input('Привет, игрок_1! Введи своё имя: ')

name_2 = input('Привет, игрок_2! Введи своё имя: ')

print('Бросок кубика для игрока', name_1, '...')

number_1 = randint(1, 6)

print('Игроку', name_1, 'выпало значение', number_1)

print('Бросок кубика для игрока', name_2, '...')

number_2 = randint(1, 6)

print('Игроку', name_2, 'выпало значение', number_2)

if (number_1 > number_2):

   print('Победил игрок', name_1)

elif (number_2 > number_1):

   print('Победил игрок', name_2)

else:

   print('У нас ничья!')

Объяснение:

Кубик имеет значения 1, 2, 3, 4, 5, 6.

from random import randint # импорт функции randint из библиотеки random

name_1 = input('Привет, игрок_1! Введи своё имя: ') # Ввод имени первого игрока с клавиатуры

name_2 = input('Привет, игрок_2! Введи своё имя: ') # Ввод имени второго игрока с клавиатуры

print('Бросок кубика для игрока', name_1, '...') # Вывод сообщения

number_1 = randint(1, 6) # генерация рандомного значения в диапазоне [1..6]

print('Игроку', name_1, 'выпало значение', number_1) # Вывод сообщения

print('Бросок кубика для игрока', name_2, '...') # Вывод сообщения

number_2 = randint(1, 6) # генерация рандомного значения в диапазоне [1..6]

print('Игроку', name_2, 'выпало значение', number_2) # Вывод сообщения

if (number_1 > number_2): # Если число первого игрока > числа второго игрока

   print('Победил игрок', name_1) # Вывод сообщения

elif (number_2 > number_1): # Если число второго игрока > числа первого игрока

   print('Победил игрок', name_2) # Вывод сообщения

else: # Иначе

   print('У нас ничья!') # Вывод сообщения

0,0(0 оценок)
Ответ:
YomiTan
13.02.2020 06:57

1)

amount = 0

for i in range(1, 51):

   if (i % 2 == 0):

       amount += i

print(amount)

2)

from random import randint

lst = [randint(1, 100) for i in range(10)]

print(lst)

for i in range(len(lst)):

   lst[i] //= 2

print(lst)

Объяснение:

Парные числа - числа, которые делятся на 2 без остатка.

1)

amount = 0 // Переменная, хранящая сумму, равна нулю

for i in range(1, 51): // Берём элементы от 1 до 50 (первые 50 натуральных чисел)

   if (i % 2 == 0): // Если число делится на 2 без остатка

       amount += i // Сумма = сумма + i

print(amount) // Вывод ответа

2)

from random import randint // импорт функции randint() из библиотеки random

lst = [randint(1, 100) for i in range(10)] // Создание списка из рандомных чисел в диапазоне [1..100], состоящего из 10 элементов.

print(lst) // Выводим список

for i in range(len(lst)): // Берём индексы каждого элемента списка

   lst[i] //= 2 // Делим значение списка с индексом i на 2

print(lst) // Выводим список

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота