vikafemur
25.04.2021 03:32

Составьте программу, определяющую является ли введённое пользователем трехзначное число "перевёртышом", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево. На языке PYTHON

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
seniorALFEROV
18.05.2020 01:18

Это как пример, если это сложно напишите комментарий под этим ответом)

Строим прямоугольник размером 8 метров на 6 метров с вершиной в начале координат. Для обеспечения точных построений вводим с клавиатуры числа 8, 6. Можно числа перечислить через точку с запятой — 8; 6. Введенные значения автоматически считываются после нажатия клавиши Enter.

Контролировать размеры построенного объекта можно с окна Размеры, расположенного в нижней части экрана в строке состояния. Превратим плоский прямоугольник в объёмный параллелепипед с инструмента Вдавить/Вытянуть (Push/Pull).

Помещаем инструмент Вдавить/Вытянуть на поверхность прямоугольника. Прямоугольник выделится точками. Зажимаем левую клавишу мыши, и тянем вверх по направлению вертикальной синей оси. Указываем с клавиатуры размер 3 (метра). Для подтверждения действия нажимаем клавишу Enter.

Объяснение:

0,0(0 оценок)
Ответ:
anavysockaa2060
09.01.2021 09:22

#include <bits/stdc++.h>

using namespace std;

int a[2000005];

int main()

{

   long long n, sum = 0;

   cin >> n;

   vector <int> v;

   for (int i = 0; i < n; ++i) {

       cin >> a[i];

       if (i < n / 3)

           v.push_back (a[i]);

   }

   sort (v.begin (), v.end ());

   for (int i = 0; i < v.size (); ++i)

       cout << v[i] << " ";

   for (int i = n / 3; i < n; ++i)

       cout << a[i] << " ";

   cout << "\n";

   for(int i = n - n / 3; i < n; ++i) {

       if (a[i] > 0 && a[i] % 2 == 0)

           sum += a[i];

   }

   cout << sum;

   return 0;

}

Объяснение:

Вот код

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота