ivankirichko2
30.01.2023 20:10

Написать программу вычисления Y при линейного алгоритма


Написать программу вычисления Y при линейного алгоритма

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olgaocher
04.08.2021 10:00

1. 8 бит = 1 байт, то есть для хранения каждого символа нужен 1 байт. Предложение «КОМПЬЮТЕРНЫЕ ОБЪЕКТЫ!» содержит 21 символ, то есть для хранения нужно 21 байт

2. Делим 240 МБ на 1024, чтобы узнать сколько ГБ:

240 МБ / 1024 = 0,234375 ГБ

Теперь делим 0,234375 ГБ на 1024, чтобы узнать сколько ТБ:

0,234375 ГБ / 1024 ≈ 0,00023 ТБ

3. 8 бит = 1 байт, то есть сколько символов, столько байт.

Смотрел фильм «Гарри Поттер и кубок огня»?

42 символа --> 42 байт

Домашнее задание №2.

1. Сколько битов составляет 1/3 килобайта?

1 КБ * 1024 = 1024 Байт

1024 Байт * 8 = 8192 бит

8192 / 3 ≈ 2731 бит

2.

3145728 КБ / 1024 = 3072 МБ

3072 МБ / 1024 = 3 ГБ

3. Скорость печати Иванова Ивана из 5 «Б» класса составляет 268 символов в минуту. Какой объем информации Иванов Иван напечатает за 12 минут, если для хранения одного символа приходится 16 бит? ответ зафиксируйте в килобайтах.

За 12 минут Иван напечатает:

268 * 12 = 3216 символов

Для хранения одного символа нужно 2 байт (16 бит / 8 = 2 байт)

Для хранения 3216 символов нужно:

3216 * 2 = 6432 байт

6432 байт / 1024 ≈ 6,28 КБ

4.

16 бит / 8 = 2 байт

Предложение Папка – это группа файлов. содержит 26 символов, то есть для его хранения нужно 26 * 2 = 52 байт

0,0(0 оценок)
Ответ:
иртова
27.08.2022 17:11

var

   a, n: longint;

   text: textfile;

function myMod(num, power, divider: longint): longint;

var

   rest, i: longint;

begin

   rest:=1;

   divider := abs(divider);

   for i := 1 to power do

   begin

       rest := rest * num;

       rest := rest mod divider;

   end;

   

   myMod := rest;

end;

begin

   assign(text, 'input.txt');

   

   {rewrite(text);

   writeln(text, 1);

   close(text);}

   

   reset(text);

   read(text, a);

   writeln('a=', a);

   close(text);

   

   n := 0;

   repeat

       n := n + 1;

   until MyMod(n, n, a) = 0;

   

   writeln('n=', n);

   assign(text, 'output.txt');

   rewrite(text);

   writeln(text, n);

   close(text);

   

   {reset(text);

   read(text, n);

   writeln('n=', n);

   close(text);}

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота