Anny2107
01.10.2021 02:11

Напишите программу, которая определяете сумму квадратов нечетных чисел от 5 до 100

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikitinaalens78
31.05.2021 00:13

#include "stdafx.h"

#include < iostream>

using namespace std;

 

int main(int argc, char* argv[])

{

    cout < < "obrabotka massiva" < < endl;

    int array1[16] = { 5, -12, -12, 9, 10, 0, -9,

                    -12, -1, 23, 65, 64, 11, 43, 39, -15 }; // объявление и инициализация одномерного массива

    cout < < "indeks" < < "\t\t" < < "element massiva" < < endl; // печать заголовков

    for (int counter = 0; counter < 16; counter++)   //начало цикла

    {

    //вывод на экран индекса ячейки массива, а затем содержимого этой ячейки, в нашем случае - это целое число

    cout < < "array1[" < < counter < < "]" < < "\t\t" < < array1[counter] < < endl;

    }

    system("pause");

    return 0;

}

0,0(0 оценок)
Ответ:
helpplease14
18.11.2021 15:01
Var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real;

procedure nod( var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real; );
var a:array[1..6] of real;
i : integer;
begin
dv1:=100;
tr1:=100;
pt1:=100;
for i:= low(a) to high (a) do begin
readln(a[i]);
repeat
if( (a[i] mod 2) =0) then begin
a[i]:=a[i]/2;
dv:=dv+1;
end
else if( ( a[i] mod 3)=0) then begin
a[i]:=a[i]/3;
tr:=tr+1;
end
else if ( ( a[i] mod 5)=0) then begin
a[i]:=a[i]/5;
pt:=pt+1;
end;

untill(a=1);
if dvif trif ptdv:=0;
tr:=0;
pt:=0;
end;
if dv1>0 then dv2:=dv1*2 else dv2:=1;
if tr1>0 then tr2:=tr1*3 else tr2:=1;
if pt1>0 then pt2:=pt1*5 else pt2:=1;
nod:=dv2*tr2*pt2;
writeln(nod);
end;
begin
nod( dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 );
end.

end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота