foorsik
23.09.2020 22:13

Написать программу в паскале! вычислить в кждом столбце матрицы количество нечетных элементов. вычислить в каждой нечетной строке матрицы максимум из отрицательных элементов! : )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastya66669
17.06.2020 04:29

Проверено на Паскале АВС:

Program Studentka;
uses crt;
const n = 10;
const m = 15;
var
  matrix:array [1..n,1..m] of integer;
  i,j,max,odd: integer;
begin
  {заполняем массивы случайными числами}
  randomize;
  writeln('Массив А:');
  for i:=1 to n do
    begin
      for j:=1 to m do
      begin
        matrix[i,j]:=random(101)-50;
        write(matrix[i,j]:4);
      end;
      writeln();
    end;
{просматриваем столбцы}
  writeln('Нечётные элементы каждого столбца:');
  for j:=1 to m do
    begin
      odd:=0;
      for i:=1 to n do
        begin
          if matrix[i,j] mod 2 <>0 then odd:=odd+1;
        end;
      write(odd:4);
    end;
  writeln();
 {просматриваем нечётные строки}
  writeln('Максимум из отрицательных элементов в нечётных строках:');
  for i:=1 to n do
    begin
      if i mod 2 = 1 then
        begin
          max:=-99;
          for j:=1 to m do
            begin
              if (matrix[i,j]<0) and (matrix[i,j]>max) then
                max:=matrix[i,j];    
            end;
          if max=-99 then  
              writeln('Строка ',i,' не содержит отрицательных элементов')
            else
              writeln('Строка ',i,'   Максимум=',max);
        end;
    end;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота