12oskar12oskar
04.04.2023 12:47

Написать программу на pascal ( из гиа). заранее огромное . напишите программу, которая в последовательности натуральных чисел определяет максимальное число оканчивающееся на 3. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число - максимальное число, оканчивающееся на 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
arisha70
17.06.2020 03:27

uses crt;
var a:array[1..1000] of integer;
i,max,n:integer;
begin
clrscr;
write('n<1000, n=');
read(n);

writeln('a[i]<30000, a[i]:');
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 10=3) and (a[i]>max) then max:=a[i];
end;
write('max=',max);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота