фиксоня
23.02.2023 12:08

Составить программу и её блок-схему используя одномерные массивы: Расположить в порядке возрастания положительные элементы правого верхнего треугольника матрицы.
(Pascal)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
RedFoxTR
26.04.2020 01:40
CLS
a:
INPUT n
IF n < 1 OR INT(n) <> n OR n > 1000 THEN GOTO a
DIM a(n)
h=30000
FOR i = 1 TO n
b:
INPUT a(n)
IF a(n) < 1 OR INT(a(n)) <> a(n) OR a(n) > 30000 THEN GOTO b
IF INT ((a(n) - 4 ) / 10) = ((a(n) - 4) / 10) AND a(n) < h THEN h = a(n)
NEXT i
PRINT h
END
или:
n - количество чисел
i - цикловая переменная
a  - натурально число
min  - минимальное число, оканчивающееся на 4
Язык програмирования: Паскаль
var
n,i,a,min: integer;
begin
readln(n);
min := 30001;
for i := 1 to n do
begin
readln(a);
if (a mod 10 = 4) and (a < min) then
min := a;
end;
writeln(min)
end.
0,0(0 оценок)
Ответ:
florzy
25.06.2021 06:15

#include <iostream>

#include <list>

int main()

{

   std::list<int> numbers;

   int x= 0;

   std::cin >> x;

   do {

       int k = x % 10;

       x /= 10;

       numbers.push_back(k);

   } while (x > 0);

   

   for (int n : numbers) {

       std::cout << n<<"\n";

   }

   return 0;

}

Класс list

Класс списка стандартной библиотеки C++ — это шаблон класса контейнеров последовательностей, который сохраняет свои элементы в линейном упорядочении и позволяет выполнять операции вставки и удаления в любом расположении в последовательности. Последовательность хранится в виде двунаправленного связанного списка элементов, каждый из которых содержит элемент какого-либо типа Type .


Сделать программу которая на фото только должен быть массив,ввод чисел с клавиатуры(с++,программа де
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота