dasha1975
07.06.2020 09:15

Python Напишите фрагмент программы, который вычисляет количество ненулевых элементов матрицы в переменной count.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
beysekeevadaniy
04.04.2022 07:43
Цикл for

program raf105;

var n,a,x,i:integer;

begin

write('Введите количество учеников: ');

readln(n);

writeln('Вводите кол во правильно решённых вопросов учеников по очереди: ');

for i:=1 to n do

begin

 readln(a);

 if a<5

   then x:= x+1;

end;

writeln('Учениками было получено ',x,' неудовлетворительных оценок');

end.

Цикл while

program raf105;

var n,a,x,i:integer;

begin

write('Введите количество учеников: ');

readln(n);

writeln('Вводите кол во правильно решённых вопросов учеников по очереди: ');

while i<>n do

begin

 i:= i+1;

 readln(a);

 if a<5

   then x:= x+1;

end;

writeln('Учениками было получено ',x,' неудовлетворительных оценок');

end.

Цикл repeat

program raf105;

var n,a,x,i:integer;

begin

write('Введите количество учеников: ');

readln(n);

writeln('Вводите кол во правильно решённых вопросов учеников по очереди: ');

repeat

 i:= i+1;

 readln(a);

 if a<5

   then x:= x+1;

until i=n;

writeln('Учениками было получено ',x,' неудовлетворительных оценок');

end.

Язык PascalABC
0,0(0 оценок)
Ответ:
bosschornoguz
04.04.2022 07:43

Написано на с++

//WlAY...

#include <iostream>

using namespace std;

int main()

{

   int N;

   cout << "Введите число учеников ->";

   cin >> N;

   if (N < 1)

   {

       cout << "ОШИБКА(учеников меньше 1)" << endl;

   }

   if (N > 30)

   {

       cout << "ОШИБКА(учеников  больше 30)" << endl;

   }

   else

   {

       int b[N];

       int i;

       int n1 = 0, n2 = 0, n3 = 0;

       for (i = 0; i <= N - 1; i++)

       {

           cout << "Введите кол-во правильно решённых примеров ученика номер" << i + 1 << "->";

           cin >> b[i];

           if (b[i] == 10)

               cout << "ОШИБКА(заданий всего 10)";

           if (b[i] == 10)

               n1 += 1;

           if (b[i] < 10 && b[i] >= 5)

               n2 += 1;

           if (b[i] < 5)

               n3 += 1;

       }

       cout << "---------------------ИТОГ-------------------------" << endl;

       cout << n1 << " ученик(а, ов) решил(и) все задания правильно (YES)" << endl;

       cout << n2 << " ученик(а, ов) получил(и) удовлетворительную оценку (NO)" << endl;

       cout << n3 << " ученик(а, ов) получил(и) неудовлетворительную оценку (NO)" << endl;

   }

}


Напишите программу для решения следующей задачи. На контрольной работе по алгебре ученикам 9 класса
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота