Ева433
28.02.2020 19:39

Переведите с Pascal на С
begin
write('Введите символ: ');
readln(c);
case c of
'0'..'9' :writeln('digit');
'A'..'Z','a'..'z':writeln('lat');
'А'..'Я','а'..'я':writeln('rus');
else writeln('Другой символ');
end;
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
BoomerLass
06.02.2020 04:28
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
function Euclid(a,b:integer):integer;
begin
  while a<>b do if a>b then a-=b else b-=a;
  Result:=a
end;

begin
  var a,b,c,d:integer;
  Write('Числитель и знаменатель первой дроби: ');
  Read(a,b);
  Write('Числитель и знаменатель второй дроби: ');
  Read(c,d);
  var zn:=b*d;
  var ch:=a*d-c*b;
  var sgn:=Sign(ch); ch:=Abs(ch);
  var gcd:=Euclid(ch,zn);
  Write('Результат вычитания: ');
  if sgn=-1 then Write('-');
  Writeln(ch div gcd,'/',zn div gcd)
end.

Тестовое решение:
Числитель и знаменатель первой дроби: 7 12
Числитель и знаменатель второй дроби: 3 4
Результат вычитания: -1/6
0,0(0 оценок)
Ответ:
1)     неА     А         неA ⇒A
          0        1             1
           1        0             0
Данное выражение ложно, когда А-ложно и истинно, когда А истинно.

2)  A  B       B⇒A  или В
     0  0              1
     0  1              1
      1 0               1
     1   1              1      Всегда истинно ( тождественно истинно)
3)  F - данное выражение
A  B  C    A⇒(B⇒C)     (A⇒B) ⇒(A⇒C)     F
0  0    0      1                      1                      1
0  0    1      1                      1                      1
0   1    0     1                      1                       1
0    1   1     1                       1                     1
1    0   0      1                      0                     0
данное выражение не тождественно истинно

8)  P*¬Q  + Q*R + ¬ P*¬Q = ¬Q*(P +¬P) + Q*R = ¬Q +Q*R

7)  X  Y  Z     X*(Y+Z)     XY + XZ
     0    0  0        0                  0
     0    0  1        0                  0
     0     1  0       0                  0                  
     0      1  1      0                  0
     1     0   0       0                 0
     1    0    0       0                  0
      1    0    1      1                  1
      1    1    0      1                  1
       1    1   1       1                  1                   Равенство док-но

A  B     ¬(A +B)    ¬A *¬B
0     0         1            1
0     1         0            0
1    0          0             0
1    1          0            0        Равенство док-но
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота