akolosov2002
31.08.2020 23:45

Напишите программу автоматического включения светодиодов в тёмное время датчика освещённости меня 300 с возможностью отключения свет податься номером светлое время суток светодиодов автоматически выключается

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
knestor
24.08.2021 13:08

1.Датчик цвета — это цифровой датчик, который может определять цвет или яркость света, поступающего в небольшое окошко на лицевой стороне датчика . Этот датчик может работать в трех разных режимах: в режиме «Цвет», в режиме «Яркость отраженного света» и в режиме «Яркость внешнего освещения» .

2.незнаю

3.Датчик цвета позволяет определять цвет поверхности. ... Принцип работы: Датчик цвета имеет два основных компонента -трехцветный (RGB) светодиод, который излучает красный, синий и зеленый свет, а также светочувствительный датчик (фоторезистор), который определяет интенсивность падающего на него света.

0,0(0 оценок)
Ответ:
danpro3
22.11.2021 04:46

Потное задание

#include <stdio.h>

#include <stdlib.h>

#include <time.h>

 

/*

*

*  Сформировать массив из N элементов (N<50) , которыми могут быть только целые числа 0 и 1.  

*  Проверить, существует ли строгое чередование 0 и 1.

*

*/

 

#define ARR_SIZE 10

 

int main(void){

   int arr[ARR_SIZE], i;

   

   srand(time(NULL));

   

   printf("\nArray: ");

   for ( i = 0; i < ARR_SIZE; ++i )

       printf("%d ", (arr[i] = rand() % 2));

   

   for ( i = 1; i < ARR_SIZE && arr[i] != arr[i-1]; ++i )

       ;

   printf("\nIs %s\n", ( i == ARR_SIZE ) ? "good" : "bad");

   

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота