MariKharlova
06.12.2020 22:41

Контрольная работа по теме «Начала программирования». Вариант I

В заданиях группы А выбрать правильный ответ.

А1. Что из нижеперечисленного не входит в алфавит языка Паскаль?

латинские строчные и прописные буквы,

арабские цифры,

русские строчные и прописные буквы,

знак подчёркивания.

А2. Какая последовательность символов может служить именем программы в языке Паскаль?

_test, 2) nos_56, 3) 56_ttt, 4)Игорь78.

А3. Обозначение целочисленного типа данных в языке Паскаль.

integer, 2) real, 3) char, 4) string.

А4. В результате выполнения фрагмента программы:

a:=3,14;

writeln (frac(a));

на печать будет выведено:

14, 2) 3.14, 3) 3, 4) 3,14.

А5. В каком из условных операторов допущена ошибка?

if b=0 then writeln ( ‘Деление не возможно‘);

if a

if a>b then max:=a else max:=b;

if (a>b) and (b>0) then c:=a+b.

А6. В результате выполнения фрагмента программы

a:=5;

b:=20;

a:=a-b/2;

if a>b then c:=a+b else c:=b-a;

переменная с примет значение:

25, 2) 14,5, 3) -15, 4) -14,5.

А7. Цикл во фрагменте программы :

a:=0.5;

s:=0;

i:=0;

repeat i:=i+1; b:=1/i; s:=s+a; until b

выполнится

0 раз, 2) 2 раза, 3) 1 раз, 4) 4 раза.

А8. С оператора while в языке Паскаль программируется:

цикл - ПОКА, 2) цикл с параметром, 3) цикл – ДО, 4) все вышеперечисленные.

В заданиях группы Б представить полное решение или записать ответ.

Б1. Определите значение переменной b после выполнения фрагмента программы:

a:=4;

b:=3;

a:=12/a*b;

b:=a+b*2.

В ответе укажите одно целое число – значение переменной b.

практическая работа
написать программу вывода всех чисел [1056..50689], которые делятся нацело на 3 и на 6, но не делится на 8,9 и 5

​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vlad777888666
10.03.2022 02:51
1. Первый интервал 21-30, в него входят 10 чисел (21,22,23,24,25,26,27,28,29,30) = а вероятность будет равна количеству чисел этого интервала к общему интервалу [1;100]. Таким образом для первого интервала 10/100 = 10% = 0,1.
2.Идем по аналогии с предыдущим интервалом : [31;55] - это 25 чисел,следовательно 25/100=25% = 0,25.
3.Интервал [25;100] - это 75 чисел. 75/100=75%=0,75.
4. Ровно 25, это единственное число,а как вы уже успели заметить - каждое число является 1 процентом. Таким образом можно сразу сказать что вероятность для этого случая 1% или 0,01.

ответ: 0.1 ; 0.25 ; 0.75 ; 0.01.
0,0(0 оценок)
Ответ:
Nazarkadm
26.07.2021 10:05

PASCAL ABC

program z1;  

var a,s:integer;  //описание переменных

begin

readln(a);  //вводим первое число

s:=0;  //начальное значение суммы

while a<>0 do //условие ввода (ввод оканчивается нулем)

 begin

   if (a mod 10=4) and (a mod 6=0) then s:=s+a;  //проверка двух условий:                           первая скобка - оканчивается на 5, вторая - кратно 6

   readln(a) //заново вводим число

 end;

writeln(s)  //вывод суммы, когда весь цикл завершится

end.

P.S не особо понимаю, почему с таким вводом, такой ответ у тебя получается

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота