anna47983
28.08.2020 16:50

Составить блок-схемы и написать программу для решения задачи Вычислить n!!=1*3*5*..*(последнее нечетное число, меньшее n, если n - четно).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mineroma50Romaaa
19.06.2022 15:16

На заводе заранее предустанавливают ПО для многих комплектующих и конечному пользователю нет нужды с этим заморачиваться, но для любой железки оно необходимо!

Системная плата - DDos protector 300

Процессор - BlackMagick 3

Оперативная память - Aezakmi

Корпус - болты и саморезы :)

Источники питания - kcas

Накопитель на жестких дисках - SSD

Накопитель CD–ROM/DVD–ROM - Archaikk PRD

Клавиатура - QWERTY

Мышь - макросы могут быть разные, самый распространенный - BFG

Видеоадаптер - Atari

Монитор - ScreenShader

Звуковая плата - Electronika-060-stereo

Модем - VSnet

Объяснение:

0,0(0 оценок)
Ответ:
Dima890438
06.07.2022 09:00

import sys

A = int(input())

B = int(input())

C = int(input())

D = int(input())

K = int(input())

def check(x, y):

   if abs(x) > K or abs(y) > K:

       return 0

   y += A

   if y >= K:

       return A - (y - K)

   x += B

   if x >= K:

       return A + B - (x - K)

   y -= C

   if y <= -K:

       return A + B + C - (-y - K)

   x -= D

   if x <= -K:

       return A + B + C + D - (-x - K)

   return -1

if check(0, 0) != -1:

   print(check(0, 0))

   sys.exit(0)

x = B - D

y = A - C

left = 0

right = 10 ** 9

while right - left > 1:

   mid = (left + right) // 2

   if check(x * mid, y * mid) == -1:

       left = mid

   else:

       right = mid

print(right * (A + B + C + D) + check(x * right, y * right))

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота