kristinaabrosi1
01.08.2021 06:36

1-вариант Составьте программу для рисования данного рисунка.
используя возможности оператора CIRCLE

медведь
.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vanek255
10.10.2022 19:59
Это, конечно, ужасный вариант с "много Copy", но если надо ...
Program primer4; 
var s:string; i,k:integer; 
begin 
writeln('подсчет количества глухих согласных в тексте'); 
writeln('введите текст'); 
readln(s); 
k:=0; 
for i:=1 to length(s) do 
 if (copy(s,i,1)='к')or(copy(s,i,1)='п')or(copy(s,i,1)='с')or
    (copy(s,i,1)='т')or(copy(s,i,1)='ф')or(copy(s,i,1)='х')or
    (copy(s,i,1)='ц')or(copy(s,i,1)='ч')or(copy(s,i,1)='ш')or(copy(s,i,1)='щ')
  then k:=k+1;
writeln(k);
end.

Пример:
подсчет количества глухих согласных в тексте
введите текст
подсчет количества глухих согласных в тексте
17
0,0(0 оценок)
Ответ:
89269705621
21.01.2023 12:27

Вычитание выполнено в шестеричной системе счисления.

Объяснение:

Мы видим в данном выражении цифры до 4. Из этого следует, что система счисления использует не менее 5 цифр. То есть, она как минимум - пятиричная. Будем подбирать по порядку системы счисления и вычислять их значения.

Пятиричная система счисления:

1. Переводим в десятичную систему счисления:

102 = 25 * 1 + 5 * 0 + 1 * 2 = 25 + 0 + 2 = 27

14 = 5 * 1 + 1 * 4 = 5 + 4 = 9

2. Вычисляем в десятичной системе счисления:

27 - 9 = 18

3. Переводим в пятиричную систему счисления:

18 = 33

Вывод: данная система счисления не подходит.

Шестеричная система счисления:

1. Переводим в десятичную систему счисления:

102 = 36 * 1 + 6 * 0 + 1 * 2 = 36 + 0 + 2 = 38

14 = 6 * 1 + 1 * 4 = 6 + 4 = 10

2. Вычисляем в десятичной системе счисления:

38 - 10 = 28

3. Переводим в шестеричную систему счисления:

28 = 44

Вывод: данная система счисления подходит.

УДАЧИ! ОБРАЩАЙТЕСЬ!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота