алсу150
19.03.2020 10:57

2) Составьте программу в Python, которая будет выводить на экран рисунок ракеты

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lapohka181202
25.10.2020 01:17
Вариант 1

Добавить в цикл счётчик

(в данном случае счётчик - b)

program raf105;

var

 a,b: integer;

begin

 readln(a);

 while a < 100 do

 begin

   a:= a+2;

   b:= b+1;

 end;

 writeln('Цикл сделал ',b,' шагов');

end.

Вариант 2Расписать все действия

(Если нет возможности запустить программу)

program raf105;

var

 a: integer;

begin

 readln(a);

 while a < 100 do

   a:= a+2;

end.

Задача:

Определить количество шагов цикла

Условие:

Ввод: 91

 Начало

 91 < 100 Истина

1. a = 91 + 2 = 93

 93 < 100 Истина

2. a = 93 + 2 = 95

 95 < 100 Истина

3. a = 95 + 2 = 97

 97 < 100 Истина

4. a = 97 + 2 = 99

 99 < 100 Истина

5. a = 99 + 2 = 101

 101 < 100 Ложь

 Конец

5 шагов

0,0(0 оценок)
Ответ:
nozim21tx
09.02.2022 16:33
Уже отвечал, но все же такое решение актуальнее: 

var 
ar:array[1..10] of integer;
max,min,i,kmax,kmin:integer;
begin
randomize;

max:=0;
min:=1000;

for i:=1 to 10 do begin  
ar[i]:=random(1000)+1;  
if (ar[i] > max) then 
  begin max:=ar[i]; kmax:=i; end 
    else if (ar[i] < min) then begin min:=ar[i]; kmin:=i; 
end;  
write(ar[i],' ');
end;

writeln();

if (kmax > kmin) then for i:=kmin+1 to kmax-1 do write(i,' ') 
  else if (kmax < kmin) then for i:=kmax+1 to kmin-1 do write(i,' ');
end.

P.S. В решении выше есть далеко ни одна ошибка ;)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота