deminav733
06.05.2021 07:23

написать программу, которая будет считать вес текста и выводить его в битах, байтах, килобайтах и мегабайтах

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
04812
16.03.2021 11:36

мне кажется что это Pascal

Объяснение:

Ключевые особенности PascalABC.NET

Ряд расширений языка Pascal, в числе которых оператор foreach, внутриблочные описания переменных, автоопределение типа при описании, встроенные множества произвольных типов, case по строкам, упрощенный синтаксис модулей, методы в записях, операция new для создания объектов, определение тел методов внутри классов, целые произвольной длины, многомерные динамические массивы.

Самые современные средства языков программирования: обобщенные классы и подпрограммы, интерфейсы, перегрузка операций, λ-выражения, исключения, сборка мусора, методы расширения, безымянные классы, автоклассы.

Генерация эффективного кода для платформы .NET.

Высокая совместимость с Delphi.

Высокая скорость выполнения программ.

Возможность доступа к огромному количеству .NET-библиотек от контейнерных классов до средств работы с сетью.

Среда разработки с встроенным отладчиком, обеспечивающая подсказки по коду, переход к определению и реализации подпрограммы, шаблоны кода, автоформатирование кода.

Встроенный в среду разработки дизайнер форм для быстрого создания оконных приложений.

Простые и эффективные графические библиотеки (растровая, векторная и трёхмерная) для создания простых визуализаций и анимаций.

Средства параллельного программирования в виде директив OpenMP.

Встроенный электронный задачник Programming Taskbook.

Модули исполнителей Робот и Чертежник, используемых в школьной информатике.

Механизм проверяемых заданий, обеспечивающий автоматическую постановку и проверку заданий.

Возможность запуска консольного компилятора под Mono в современных версиях Linux, возможность встраивания PascalABC.NET в редактор Geany.

Система PascalABC.NET является совместной разработкой российских и немецких программистов. В России центр разработки находится в институте математики, механики и компьютерных наук Южного федерального университета.

PascalABC.NET активно используется в ряде средних и высших учебных заведений России и ближнего зарубежья. Так, на мехмате Южного федерального университета он используется для обучения 1 курса направления Фундаментальная информатика и информационные технологии в курсе Основы программирования, а также для обучения школьников в одной из самых больших в России Детской компьютерной школе.

0,0(0 оценок)
Ответ:
FlUSHWER
16.03.2021 11:36

program z1;

var

s:string;

begin

write('Введите строку: ');

read(s);

writeln(length(s)*8,' бит');

writeln(length(s),' байт');

writeln(length(s)/1024,' Кбайт');

writeln(length(s)/1024/1024,' Мбайт')

end.

Объяснение:

i = 8 бит = 1 байт (информационный вес одного символа )

Вводим строку (текст)

Функция length - количество символов (длина строки)

1 байт = 8 бит

1 Кбайт = 1 024 байт

1 Мбайт = 1 024 Кбайт

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота