katyaivanova17
01.10.2021 10:21

Составьте программу создания изображения с исполнительным роботом с использованием процедуры скорее​


Составьте программу создания изображения с исполнительным роботом с использованием процедуры скорее​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ДмитрийJ
27.07.2021 11:49
program parampampam; 
uses crt; 
var 
i: integer; {счетчик} 
s: integer; 
begin 
clrscr; {очистка экрана} 
writeln ('Программа выводит числа от 1 до 99, сумма цифр которых равна числу S'); 
writeln ('Введите число S, от 0 до 18: '); 
{ввод числа S с проверкой на корректность} 
repeat 
readln (s); 
if (s>18) or (s<0) then 
writeln ('Неверный ввод. Повторите') 
until (s<=18) and (s>=0); 
{вывод нужных чисел на экран (цикл с предусловием)} 
for i := 1 to 99 do 
if ((i div 10) + (i mod 10) = s) then {div дает целую часть, mod - остаток от деления} 
write (i, ' '); 
repeat until keypressed; {пустой цикл для задержки экрана до нажатия клавиши} 
end.
0,0(0 оценок)
Ответ:
lukash231082
27.07.2021 11:49

Объяснение:

1. x = 0; y = 4

Цикл по i от 3 до 6

1) i = 3

x = x + 1 = 0 + 1 = 1

y = y + 2 = 4 + 2 = 6

2) i = 4

x = x + 1 = 1 + 1 = 2

y = y + 2 = 6 + 2 = 8

3) i = 5

x = x + 1 = 2 + 1 = 3

y = y + 2 = 8 + 2 = 10

4) i = 6

x = x + 1 = 3 + 1 = 4

y = y + 2 = 10 + 2 = 12

Конец цикла

y = y - x = 12 - 4 = 8

x = x + y = 4 + 8 = 12

Вывод y = 8

2. x = 0; y = 2

Цикл, пока y < 15

1) x = x + 1 = 0 + 1 = 1

y = y + 2 = 2 + 2 = 4 < 15

2) x = 1 + 1 = 2

y = 4 + 2 = 6 < 15

3) x = 2 + 1 = 3

y = 6 + 2 = 8 < 15

4) x = 3 + 1 = 4

y = 8 + 2 = 10 < 15

5) x = 4 + 1 = 5

y = 10 + 2 = 12 < 15

6) x = 5 + 1 = 6

y = 12 + 2 = 14 < 15

7) x = 6 + 1 = 7

y = 14 + 2 = 16 > 15

Конец цикла

y = y - x = 16 - 7 = 9

x = x + y = 7 + 9 = 16

Вывод y = 9

3. x = 0; y = 5

Цикл с постусловием

1) x = x + 1 = 0 + 1 = 1

y = y + 2 = 5 + 2 = 7

Выйти из цикла, если y > 15

y = 7 < 15

2) x = 1 + 1 = 2

y = 7 + 2 = 9 < 15

3) x = 2 + 1 = 3

y = 9 + 2 = 11 < 15

4) x = 3 + 1 = 4

y = 11 + 2 = 13 < 15

5) x = 4 + 1 = 5

y = 13 + 2 = 15

15 не больше 15, поэтому продолжаем.

6) x = 5 + 1 = 6

y = 15 + 2 = 17 > 15

Выход из цикла

y = y - x = 17 - 6 = 11

x = x + y = 6 + 11 = 17

Вывод y = 11

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота