run5555
16.09.2021 19:41

1 Дан массив из n элементов. Требуется посчитать их сумму и произведение.

Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) — размер массива. В следующей строке вводятся n элементов массива через пробел. Все элементы не превосходят по модулю 10 и являются целыми числами.
Формат выходных данных
Необходимо вывести два числа в одной строке — сумму и произведение всех элементов массива. Гарантируется, что эти числа не превосходят по модулю 109.
входные данные
2
5 6
выходные данные
11 30

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
4568633
14.06.2020 22:51
Объявим нужные переменные
Нам потребуется sum(сумма), average(ср. арифм), i(для цикла), n(кол-во чисел), x(введенное значение), count(счетчик нечетных)
Присваиваем переменной n(кол-во чисел) нужное значение.
Обнуляем summ и count
Организовываем ввод чисел с клавиатуры через цикл от 0 до n
Внутри цикла делаем проверку на четность, примерно так:
if x mod 2 = 1 then (mod 2 обозначает остаток от деление на 2)
А здесь увеличиваем переменную sum = sum + x
И счетчик count = count + 1

Теперь после того как все итерации пройдены
Переменная sum хранит значение суммы нечетных чисел.
А переменную average надо разделить на count. average = average / count
Так мы получим ср. арифметическое для всех нечетных чисел.

Выводим значение sum и average.
0,0(0 оценок)
Ответ:
Marta2910
14.06.2020 22:51
//PascalABC
//NaaMan
var
    N, sum, num, i : integer;
    A : array[1..10000] of integer;
    SA : real;
begin
    write('Укажите, сколько будет чисел > ');
    readln(N);
    write('Вводите элементы массива > ');
    // Обнуляем сумму
    sum := 0;
    // и количество искомых элементов
    num := 0;
    // Ввод элементов массива с одновременным подсчетом
    for i := 1 to N do begin
        // Ввод
        readln(A[i]);
        write('Ещё > ');
        // Если введённое нечётное, то
        if A[i] mod 2 = 1 then begin
            // добавляем к сумме
            sum := sum + A[i];
            // и считаем их количество
            num := num + 1;
        end;
        // Это среднее арифметическое
        SA := sum / num;
    end;
       
    writeln('Сумма элементов ', sum);
    writeln('Среднее арифметическое ', SA);
end.

Составьте программу , которая считывает с клавиатуры n чисел и находит сумму и среднее арифметическо
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота