odolskij2016
04.07.2022 01:20

Напишите программу по блок схеме Даю 20б.


Напишите программу по блок схеме Даю 20б.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Jions
02.02.2020 07:07
При использовании random() упорядоченные строки получаются редко. Можете массив вводить с клавиатуры.
const n=5; m=4;
var 
a:array[1..n,1..m] of integer;
i,j,max:integer;
b1,b2:boolean;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(100);
   write(a[i,j]:4);
  end;
  writeln;
 end;
max:=-1000;
for i:=1 to n do
 begin
 b1:=true; b2:=true;
 for j:=1 to m-1 do
  begin
  if a[i,j]<a[i,j+1] then b1:=false;
  if a[i,j]>a[i,j+1] then b2:=false;
  end;
 if b1 or b2 then
  for j:=1 to m do
   if a[i,j]>max then max:=a[i,j];
 end;
if max<>-1000
 then writeln('max = ',max)
 else writeln('В массиве нет упорядоченных строк');
end.

Пример:
45 34 88 53
 2 7 36 71
48 57 28 42
75 61 10 93
15 3 61 54
max = 71
0,0(0 оценок)
Ответ:
MiroshDalia
28.12.2021 11:47
Program P7;
var S:String; n,k1,k2,k3,i:byte;
Begin
writeln('Введите строку:');
readln (S);
n:=length (S);
k1:=0; k2:=0; k3:=0;
For i:=1 to n do 
case S[I] of 
' ' : k1:=k1+1;
',',';','.','!',':','?' : k2:=k2+1;
'b','c','d','f','g','k','l','m','n','p','r','s','t': k3:=k3+1
end;
Writeln ('kolicestvo clov = ',k1+1);
Writeln ('kolicestvo znakov prepinania = ',k2);
writeln('kolicestvo soglasnih = ', k3);
readkey
end.

Пример:
Введите строку:
na ulite sneg.
kolicestvo clov = 3
kolicestvo znakov prepinania = 1
kolicestvo soglasnih = 6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота