nastorekhova20
23.12.2022 03:35

Составить программу линейной структуры алгоритмов позязь


Составить программу линейной структуры алгоритмов позязь

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Тилилинка
18.05.2022 03:36
DIM Nazv1$, Nazv2$
DIM P1%,O1%,D1%,P2%,O2%,D2%

CLS
INPUT "Nazvanie 1: ", Nazv1$
INPUT "Perviy: ", P1
INPUT "Otvetniy: ", O1
INPUT "Nazvanie 2: ", Nazv2$
INPUT "Perviy: ", P2
INPUT "Otvetniy: ", O2
IF P1+O1>P2+O2 THEN
   PRINT Nazv1$
ELSE
   IF P1+O1<P2+O2 THEN
      PRINT Nazv2$
   ELSE
      IF O1-O2>P2-P1 THEN
         PRINT Nazv1$
      ELSE
         IF O1-O2<P2-P1 THEN
            PRINT Nazv2$
         ELSE
            PRINT "Dopolnitelnoe:"
            PRINT Nazv1$
            INPUT D1
            PRINT Nazv2$
            INPUT D2
            IF D1>D2 THEN
               PRINT Nazv1$
            ELSE
               IF D1<D2 THEN
                  PRINT Nazv2$
               ELSE
                  PRINT "Nichia"
               END IF
            END IF
         END IF
      END IF
   END IF
END IF
END

Пример:

Nazvanie 1: A
Perviy: 2
Otvetniy: 0
Nazvanie 2: B
Perviy: 0
Otvetniy: 2
Dopolnitelnoe:
A
? 3
B
? 3
Nichia
0,0(0 оценок)
Ответ:
HKL11
18.05.2022 03:36
1.                                                                        

program raf105;

var n,m,i:integer;

begin

writeln('Введите диапазон чисел (2 числа через пробел) которые нужно возвести в квадрат');

readln(n,m);

writeln('Вывод:');

for i:=n to m do

 writeln(i**2)

end.

2.                                                                        

program raf105;

var a,b,kol1,kol2:integer;

begin

write('Введите число: ');

readln(a);

while a <> 0 do

begin

 b:= a mod 10;

 if b<>0

   then if (b mod 2)=0

     then kol1+= 1

     else kol2+= 1;

 a:= a div 10;

end;

writeln('В числе ',kol1,' чётных и ',kol2,' нечётных цифр');

end.

3.                                                                        

program raf105;

var n,i,kol:integer;

begin

write('Введите N: ');

readln(n);

for i:=1 to n-1 do

 if ((i mod 2)<>0) and ((i mod 3)<>0) and ((i mod 5)<>0)

   then kol+=1;

writeln('Вывод: ',kol);

end.

Язык PascalABC

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота