annahdh
17.07.2022 12:11

Написать программу которая проверяет является ли введенное число положительным или отрицательным? (составляете алгоритм на словестном, графическом и языке программирования) ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
AidarSharafutdinov
01.01.2023 02:53
Var 
mas: array[1..7] of integer;
k, i, MAX:integer;

Begin
for i:=1 to 7 do
  Begin
  writeln('Введите число');
  readln(mas[i]); 
  end;

MAX:=mas[1];
k:=1;
for i:=2 to 7 do
  Begin
    if mas[i] > MAX   
       then      
          Begin       
               MAX:=mas[i];       
                k:=1;     
          end   
       else        
            if MAX=mas[i]          
                 then k:=k+1;
  end;

writeln();
writeln('Максимальное значение = ', MAX);
writeln('Количество элементов = ', k);

readln();
end.
0,0(0 оценок)
Ответ:
Zalis1
01.01.2023 02:53
задача 1.
a=input().split()

f=-1

for i in range(len(a)):

    if int(a[i])>0 and int(a[i])%2==0:

        if f==-1:

            min1=int(a[i])

            max1=int(a[i])

            f=1

        elif int(a[i])>max1:

            max1=int(a[i])

        elif int(a[i])<min1:

            min1=int(a[i])

if f==-1:

    print('not solution')

else:

    print('max=',end='')

    print(max1)

    print('min=',end='')

    print(min1)

задача 2.

a=input().split()

k=0

max1=float(a[0])

for i in range(len(a)):

    if float(a[i])==max1:

        k+=1

    elif float(a[i])>max1:

        k=1

        max1=float(a[i])

print(k)

задача 3.

a=input().split()

min1=float(a[0])

min2=float(a[0])

min3=float(a[0])

for i in range(len(a)):

    if float(a[i])<min1:

        min3=min2

        min2=min1

        min1=float(a[i])

    elif float(a[i])<min2:

        min3=min2

        min2=float(a[i])

    elif float(a[i])<min3:

        min3=float(a[i])

print(min1)

print(min2)

print(min3)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота