arabenko
29.11.2021 18:25

ПАСКАЛЬ! Надо написать программу,которая просит пользователя ввести позитивное число, Так должно повторяться пока пользователь не введёт 0, так же программа выводит сколько двухзначных чисел ввёл пользователь
надо использовать repeat и until
даю

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Голубь20079
19.07.2022 04:08
В наихудшем случае, последнее новогоднее число - 11111111.

#include <iostream>

bool isNewYearNumber(int n);
int sumDigits(int num);
bool hasZero(int n);

int main() {
  const int LASTNEWYEARNUMBER = 11111111;
  long long sum = 0;
  for(int i = 0; i <= LASTNEWYEARNUMBER; i++)
    if ( isNewYearNumber(i) )
      sum += i;
  std::cout << "Сумма всех новогодних чисел: " << sum << '\n';
  return 0;
}

bool isNewYearNumber(int n)
{
  if ( !( hasZero(n) ) && sumDigits(n) == 8)
    return true;
  else
    return false;
}

int sumDigits(int num)
{
  int sum = 0;
  while ( num > 0 ) {
    sum += num % 10;
    num /= 10;
  }
  return sum;
}

bool hasZero(int n)
{
  if (n < 0)
    n = -1 * n;
  if (n % 10 == 0)
    return true;
  else if (n / 10 > 0)
     hasZero(n / 10);
  else
    return false;
}
0,0(0 оценок)
Ответ:
YulyaDremina
15.01.2021 11:27
Юра, Миша, Володя, Саша, Олег
Юра стоит раньше Миши, но после Олега:
                                       Первым будет Олег, за ним Юра, дальше Миша.
Саша не находится рядом ни с Олегом, ни с Юрой, ни с Володей:
                                                                                   Саша будет последний
Володя и Олег не стоят рядом:
                               Володя будет стоять между Юрой и Мишой
                                 (между Мишой и Сашой не может из-за условия више) 

ответ: ОЛЕГ, ЮРА, ВОЛОДЯ, МИША, САША
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота