stich2095
29.06.2022 16:46

Решить на c#, используя циклы. составить программу для вычисления и вывода n первых чисел фибоначчи. числа фибоначчи получаются с следующих рекуррентных соотношений где - целое. отследить корретность ввода исходных данных.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
irinkailnitska11
01.10.2020 04:47

using System;

class Program
{
public static int Fibonacci(int n)
{
int a = 0;
int b = 1;
for (int i = 0; i < n; i++)
{
int temp = a;
a = b;
b = temp + b;
}
return a;
}

static void Main()
{
Console.Write("Введите N:");
int n = Int32.Parse(Console.ReadLine());
for (int i = 0; i < n; i++)
{
Console.WriteLine(Fibonacci(i));
}
}
}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота