LaMoZzStaDt
15.01.2021 14:16

Составить программу для решения задачи. Дано 2 целых числа. Если первое число больше второго, то найти их сумму, иначе найти их произведение. *

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Асуна225
31.08.2021 13:29

Часть А

В заданиях части А выбрать только один ответ.

А1. Текстовый редактор – это приложение

1) для создания мультимедийных документов;

2) для создания, редактирования и форматирования текстовой информации;

3) для обработки изображений в процессе создания доклада.

А2. Текстовая информация-это

1) информация, представленная в форме письменного текста;

2) рисунки схемы, графики;

3) полный набор букв алфавита.

А3. Какие операции выполняют при редактировании текста?

1) Совершают операции по оформлению текста текст, исправляют ошибки, вносят изменения.

3) Выводят текст на печать.

А4. Какие из перечисленных ниже расширений соответствуют текстовому файлу?

1) exe, com, bat;

2) gif, bmp, jpg;

3) txt, doc, rtf.

А5. Какую программу нужно выбирать для обработки текстовой информации?

1) MS Excel;

2) MS Word;

3) Paint.

А6. При задании параметров страницы в текстовом редакторе устанавливаются:

1) гарнитура, начертание, размер;

2) поля, ориентация;

3) отступ, интервал.

А7. В каком из перечисленных ниже предложений правильно расставлены пробелы между словами и знаками препинания?

1) Слово не воробей , вылетит— не поймаешь!

2) Слово не воробей, вылетит — не поймаешь!

3) Слово не воробей, вылетит-не поймаешь !

4) Слово не воробей , вылетит —не поймаешь !

А8. Что такое абзац?

1) Абзац — это фрагмент текста, процесс ввода которого закончился нажатием на клавишу Esc.

2) Абзац — это фрагмент текста, процесс ввода которого закончился нажатием на клавишу Space.

3) Абзац — это фрагмент текста, процесс ввода которого закончился нажатием на клавишу Enter.

А9. К группе свойств символов можно отнести:

1) шрифт, размер шрифта, начертание и цвет;

2) выравнивание, размер шрифта, междустрочный интервал, цвет;

3) выравнивание, отступ первой строки, междустрочный интервал, отступ слева и справа, интервалы перед и после.

А10. Объем текстового файла вычисляется по формуле

1) I = K * i

2) N=2i

3) N=2*i

4) I=N+K

Так?

0,0(0 оценок)
Ответ:
tanyushchik
06.04.2022 17:46
//Решение с использованием длинной арифметики
var i, j, sum, len, rem: integer;
    mult: array[1..1205] of integer;
begin
  len := 1;
  mult[1] := 1;
  i := 100;
  while i < 1000 do
  begin
    for j := 1 to len do
    begin
      rem := mult[j] * i + rem;
      mult[j] := rem mod 10;
      rem := rem div 10;
    end;
    while rem > 0 do
    begin
      inc(len);
      mult[len] := rem mod 10;
      rem := rem div 10;
    end;
    sum := sum + i;
    i := i + 2;
  end;
  writeln('Сумма: ', sum);
  write('Произведение: ');
  for i := len downto 1 do write(mult[i]);
  writeln;
end.

Результат работы программы:
Сумма: 247050
Произведение: 11663575674444359823002008139390746528142707402328361705647495301216245827892256323421573853031635648105175857107321864360366071385039128549679496343675509640183219826717346573458260381851930244150425562315833417515264123698581740276921937117732298873364203269398167251131992557619396626253824845619285980851485012131859200089180731617159967796785692496658820266554970195579987101761437467345295469560091019643416890744175485355715583034412689664621367823158491721734017238669568797130683826947437814864890599291484009747561514288528353178159298856645624289518581586947168677504742711452824976368290519747367284033226821443792754573564848344600041433089899538479032717299413920051538113896509134682791976736868238046387230383008696853107977931851651379555533347652931008271572588724198961970056163028633888796670948358527288343719100865852117339478785474064397937004993302565523495403857150309972891503340949896943795594807214141508464167055846685872109706922589562538698747726222566785521882450614299594376824656706451033378744188256788426310583732611392640652066952551824890922829689995132928000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота