kookie04
09.09.2021 20:05

4«условный оператор» написать программу: дано четырехзначное число. определить, входит ли в него цифра 6.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
нуршат8
16.06.2020 14:49

Program spinogryz21;
var
  x, i: integer;
  yes: boolean;
begin
  yes := FALSE;
  write('Введите число Х ');
  readln(x);
  for i := 1 to 4 do
  begin
    if (x mod 10) = 6 then yes := TRUE;
    x:=x div 10;
  end;
  if yes then writeln('6 входит в число Х')
  else writeln('6 не входит в число Х');
end.

0,0(0 оценок)
Ответ:
dizi17
16.06.2020 14:49

uses crt;
var a,b,c,d,ch:integer;
begin
a:=0; b:=0; c:=0; d:=0;
readln(ch);
a:=ch div 1000;
b:= (ch div 100) mod 10;
c:=(ch div 10)mod 10;
d:=ch mod 10;
if ((a =6) or ( b = 6) or (c = 6 ) or ( d = 6)) then
writeln('YES') else writeln('NO');
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота