DianaAudley
16.12.2020 19:53

Напишите программу на c++.Условие:

Напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м, 3-й с 4-м и т.д. Нумерация элементов начинается с единицы. Если в массиве нечётное количество элементов, последний элемент остаётся на своём месте.

Входные данные

Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные

Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hdjdjndn
30.01.2021 20:47

//з № 1var s,d,f,max:integer;beginRead(s,d,f);if (s > d)and (s > f) thenmax:= selse if (d > s) and (d > f)  thenmax:= delse if (f > d) and(f > s) then max:=f;write('max ',max);end.

//з № 2 var x:real; r:integer;beginwrite('Введите число x =');Read(x);if Frac(x)=0 then beginwriteln('x - целое число!');r:=round(x);if ((r mod 2)=0) then writeln('Число четное')else writeln('Число нечетное');endelse writeln('x - дробное число!')end.

//з № 3var a:integer;beginwrite('Введите число а =');Read(a);if (a > 0)and (a <= 5) thena:= a *a*aelse if (a > 5)  thena:= a*aelsea:=a;write('a = ',a);end.

Объяснение:

0,0(0 оценок)
Ответ:
приветик49
01.02.2022 23:14
#include <algorithm>
#include <iostream>
#include <vector>

bool ToLess(int a, int b) {
    return a > b;
}

int main() {
    int count;
    std::cin >> count;
    std::vector<int> vectorOfNombers(count);
    for (size_t i = 0; i != count; ++i) {
        std::cin >> vectorOfNombers[i];
    }

    sort(vectorOfNombers.begin(), vectorOfNombers.begin() + count / 2 - 1);           sort(vectorOfNombers.begin() + count / 2, vectorOfNombers.end(), ToLess);

    for (size_t i = 0; i != count; ++i) {
          std::cout << vectorOfNombers[i] << " ";
     }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота